httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From François Conil <co...@ece.fr>
Subject [users@httpd] trying to use mod_proxy with a sso
Date Mon, 19 Dec 2005 18:01:15 GMT
hello,

After looking for an answer in the archives, I'll try asking here.

I'm currently managing a three servers set up : A sso server, a reverse 
proxy front end and a http backend.

Basically, i'm trying to have things like this work :

proxy.domain/public_app -> proxy -> backend.local/private_app -> calls 
sso -> sso.domain/auth -> redirects to public_app ->proxy.domain/public_app
(the names of the application folders aren't the same).

It works pretty fine, except that the SSO only use the X-Forwarded-for 
header to redirects the user to the right server. Problem is that it 
redirects the user to proxy_server/private_app instead of 
proxy_server/public_app.

Using the same names for private and public app names isn't a solution, 
and I would like to know which header sent to/received by the backend 
server will give me the part after *proxy.domain/* so that I can tweak 
this particular sso implementation to suits my needs.


Thanks by advance,

-- 
François Conil
Administrateur Systèmes et Réseaux
<Lenz> Oh man...
<Lenz> my mom just asked me to rewind the dvd for her




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message