httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian C <bria...@berkeley.edu>
Subject [users@httpd] User Authentication through Proxy Errors
Date Thu, 01 Dec 2005 16:53:14 GMT
Hi,

With prior help from the list I set up Apache 2.0.53 on SUSE (call it 
oldserver) to proxy requests through to another Apache server on my 
network (running 1.3.33 on Debian, call it newserver).

The relevant part of the oldserver's config looks like:

	<VirtualHost *:80>
  	  ServerName www.newwebsite.com
  	  ProxyPass / http://192.168.0.9/
  	  ProxyPassReverse / http://192.168.0.9/
  	</VirtualHost>

and the same for newwebsite.com (without the 'www')

I also had to edit /etc/sysconfig/apache2 and find the line that says
APACHE_MODULES="blah blah blah" and add "proxy" and "proxy_http" to the
list of modules.

This allows me to get to index.html on the newserver by going to 
newwebsite.com in a browser.

However, the rest of newserver's pages require user authentication and 
any attempt to go to such a page, instead of bringing up a user/password 
pop-up box, yields the following error:

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /dirname.

Reason: DNS lookup failure for: 192.168.0.9dirname

Additionally, a 502 Bad Gateway error was encountered while trying to 
use an ErrorDocument to handle the request.
Apache/2.0.53 (Linux/SUSE) Server at newwebsite.com Port 80

newserver's error_log produces the following:

[Thu Dec 01 08:50:53 2005] [error] [client 1.1.1.1] proxy: DNS lookup 
failure for: 192.168.0.9dirname returned by /dirname
[Thu Dec 01 08:50:54 2005] [error] [client 1.1.1.1] proxy: DNS lookup 
failure for: 192.168.0.9error returned by /error/HTTP_BAD_GATEWAY.html.var
[Thu Dec 01 08:50:54 2005] [error] [client 1.1.1.1] proxy: DNS lookup 
failure for: 192.168.0.9favicon.ico returned by /favicon.ico
[Thu Dec 01 08:50:55 2005] [error] [client 1.1.1.1] proxy: DNS lookup 
failure for: 192.168.0.9error returned by /error/HTTP_BAD_GATEWAY.html.var

Any thoughts on how to get the rest of newserver's web pages to proxy 
through properly?

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message