httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris <chrco...@gmail.com>
Subject [users@httpd] httpd processes spawning and causing high load and server to halt
Date Sun, 04 Dec 2005 13:53:09 GMT
Hi I am getting high load averages causes by child apache processes
spawnign, it is happening at least 5 times a week and I suspect some kind of
attack is been used on my server.  At the times of the problem I am seeing
these in my log files.

httpd in free(): error: recursive call
[Sat Dec  3 21:13:18 2005] [notice] child pid 3405 exit signal Segmentation
faul
t (11)
httpdhttpd in free(): error: recursive call
 in free(): error: recursive call
httpd in free(): error: recursive call
httpd in free(): error: recursive call
httpd in free(): error: recursive call
httpd in free(): error: recursive call
httpd in free(): error: recursive call
httpd in free(): error: recursive call
httpd in free(): error: recursive call
[Sat Dec  3 21:16:30 2005] [notice] child pid 14245 exit signal Segmentation
fau
lt (11)
[Sat Dec  3 21:16:41 2005] [notice] child pid 85258 exit signal Segmentation
fau
lt (11)
httpd in free(): error: recursive call
httpd in free(): error: recursive call
httpd in free(): error: recursive call

this continures for some time with dozens of the above line's and then I see
the following.

httpd in free(): error: page is already free
httpd in free(): error: page is already free
httpd in free(): error: page is already free
httpd in free(): error: page is already free

about 30 of them and then

[Sat Dec  3 21:43:33 2005] [warn] child process 95983 still did not exit,
sendin
g a SIGTERM
[Sat Dec  3 21:43:33 2005] [warn] child process 96182 still did not exit,
sendin
g a SIGTERM
[Sat Dec  3 21:43:33 2005] [warn] child process 96399 still did not exit,
sendin
g a SIGTERM
[Sat Dec  3 21:43:33 2005] [warn] child process 96432 still did not exit,
sendin
g a SIGTERM

they all start dieing of as above.  The problem is if unattended which is
mostly the case this can go on for over an hour, and during this time the
server is almost unresponsive.  The os is FreeBSD 5.4 apache 1.3.34 php
4.4.0 (previously 4.4.1 downgraded to see if help the issue), they kept on
dying off slowly until the server got a sighup later after which it was
normal.  The occasions it has happened whilst I was present restarting
apache always fixed it.

I need some help with this it has been on going for over a week and I am out
of idea's having rebooted, recompiled apache/php etc.

Chris

Mime
View raw message