httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fotos Georgiadis <fo...@trwn.gr>
Subject Re: [users@httpd] config for ldap in httpd.conf help please
Date Thu, 08 Dec 2005 04:06:23 GMT

On 7 Dec 2005, at 23:59, GIppolito@princetonecom.com wrote:

>
> I have finally compiled apache 2.0.55 with ldap, but now it will not
> authtencate from the ldap server.    Here is my config in httpd.conf.
> Also my debug from openldap.   It don't look like it's even trying  
> to speak
> to the ldap server.
> Please help
> Thanks
>
>
> httpd.conf  ldap config
>
> <Directory /usr/local/apache2/htdocs/ldap/>
>         SetHandler ldap-status
>         Order deny,allow
>         Deny from all
>         Allow from xxxxxxxxxxxxxxxxxxx.com
>         AuthLDAPEnabled on
>         AuthLDAPURL
> ldap://192.168.20.60:386/dc=xxxxxxxxxxxxxxx,dc=com?uid?one
>         AuthLDAPAuthoritative on
> require valid-user
>
> </Directory>

Hi,

you are missing some options in the Directory entry:
     AuthType            Basic
     AuthName          "Authenticated Users Only"

It should complain about these in the error log, with something like:
"configuration error: couldn't perform authentication. AuthType not  
set!"

-fot


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message