httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cauchy Song <cauchy.s...@gmail.com>
Subject [users@httpd] mod_cache with weglogic/tomcat
Date Mon, 26 Dec 2005 18:00:55 GMT
I configured apache 2.0 with weblogic cluster, but mod_cache no effect
with jsp. Here is httpd.conf snippet,

LoadModule cache_module modules/mod_cache.so
LoadModule disk_cache_module modules/mod_disk_cache.so
LoadModule mem_cache_module modules/mod_mem_cache.so
LoadModule weblogic_module modules/mod_wl_20.so


<IfModule mod_weblogic.c>
        #WebLogicHost 127.0.0.1
        #WebLogicPort 7001
        WebLogicCluster 192.168.0.221:7001,192.168.0.222:7001

        Debug        true
        DebugConfigInfo on # enable "__WebLogicBridgeConfig", only for debug
        WLLogFile    /var/log/httpd/web_log.log

        MatchExpression *.jsp
        ErrorPage /weblogic/error.jsp
</IfModule>

<Location /weblogic>
        SetHandler weblogic-handler
        PathTrim /weblogic
        ErrorPage /weblogic/error.jsp
</Location>


      <IfModule mod_cache.c>
        <IfModule mod_mem_cache.c>
          MCacheMaxObjectCount     524288  # avn size > 1 KB
          MCacheMinObjectSize          64  # 64 byte
          MCacheMaxObjectSize      524288  # 512 KB
          MCacheMaxStreamingBuffer 524288  # 512 KB
          MCacheSize               524288  # maximum amount of memory
used, 512 MB

          CacheEnable mem  /
          CacheDisable /admin
        </IfModule>

      </IfModule>

Thanks for some help
Mime
View raw message