httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From WJG <wjg779-apa...@yahoo.com>
Subject [users@httpd] Apache2 SSI XBitHack not working
Date Fri, 09 Dec 2005 19:32:22 GMT
I'm trying to configure SSI on Apache2 (2.0.54) on Ubuntu 5.10 Breezy 
(Debian-based). I've got .shtml working, but can't get XBitHack to work.
 
vhost config:
<Directory />
	Options -Indexes -FollowSymLinks
	AllowOverride None
</Directory>

<Directory /var/www/[mydir]>
	Options MultiViews +Includes

	AllowOverride None
	Order allow,deny
	allow from all

	XBitHack on
</Directory>

I've tried it with XBitHack in one or the other <dir>s, or both. Also tried 
"XBitHack full".

error.log (LogLevel debug):
[Fri Dec 09 13:59:06 2005] [notice] SIGHUP received.  Attempting to restart
[Fri Dec 09 13:59:06 2005] [warn] NameVirtualHost *:0 has no VirtualHosts
[Fri Dec 09 13:59:06 2005] [notice] Apache/2.0.54 (Ubuntu) configured -- 
resuming normal operations

ls -l index.*
-rwxr-xr--  1 root root 3431 2005-12-08 22:35 index.html
-rwxr-xr--  1 root root 3362 2005-12-08 01:30 index.shtml

snip of index.html source (from Firefox or Konqueror)
<!--#echo var="DATE_LOCAL" -->

snip of index.shtml source (from Firefox or Konqueror)
Friday, 09-Dec-2005 14:23:12 EST

Clearly .shtml SSI is working, but XBitHack SSI is not. I've reviewed all the 
Apache2 docs and tutorials on SSI and XBitHack that I've found, and it all 
seems very straightforward. I've restarted any number of times, touched 
index.html since chmod-ing, forced browser refreshes, etc., etc.

I've even tried adding
AddType text/html .html
AddOutputFilter INCLUDES .html

to my vhost config.
 
Since no one else seems to have this problem, it's probably something 
stupid-simple I'm doing wrong. If anyone has a clue or suggestion, it would 
be most welcome.

Jay

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message