httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William Cai <william....@gmail.com>
Subject Re: [users@httpd] Cannot Get PERL to work
Date Sat, 26 Nov 2005 06:14:53 GMT
Sorry, I have no Windows Environment right now. My suggestion is that,
1. Use "#!D:/perl/bin/perl.exe" instead of "D:\perl\bin\perl.exe"
2. Turn on Apache log

-William

On 11/26/05, Michael Avila <Michael.Avila.1@sbcglobal.net> wrote:
>
> I have done that and it still does not work.
>
>
> #!D:\perl\bin\perl.exe
> #
>
> Does that look like the right format?
>
> Mike
>
>
> -----Original Message-----
> *From:* William Cai [mailto:william.cai@gmail.com]
> *Sent:* Saturday, November 26, 2005 12:39 AM
> *To:* users@httpd.apache.org
> *Subject:* Re: [users@httpd] Cannot Get PERL to work
>
>
> I met the same problem before. If my recollection is right, the problem is
> caused by your perl script. You might have to specify the executable binary
> with absolute path.
>
> e.g.
> #!C:/perl/bin/perl.exe
> blablabla
>
> Hope it helps.
>
> -William
>
> On 11/26/05, Michael Avila <Michael.Avila.1@sbcglobal.net> wrote:
> >
> > Windows XP Pro
> > Active State PERL 5.6 (Have to have 5.6 and not 5.8 for a specific
> > application)
> > NOTE: IP Addresses and website changed to prevent hacking
> >
> >
> > QUESTION: What is it that cannot be found - admin.pl or PERL.exe or
> > something else?
> >
> >
> > ----------------------------------------------------------------------------
> > -------------------------------------------------------------------
> > httpd.conf
> > =======
> > ScriptAlias /perl "d:/perl"
> > AddType application/x-httpd-pl .pl .cgi
> > Action application/x-httpd-pl "/perl/bin/perl.exe "
> >
> >
> > Alias /sql-ledger /sql-ledger
> > <Directory /sql-ledger>
> > AllowOverride All
> > AddHandler cgi-script .pl
> > AddDefaultCharset On
> > Options ExecCGI Includes FollowSymlinks
> > Order Allow,Deny
> > Allow from All
> > </Directory>
> >
> >
> > ----------------------------------------------------------------------------
> > -------------------------------------------------------------------
> >
> > when I execute a perl script from a web browser such as
> >
> > http://www.xxxxx.com/sql-ledger/admin.pl
> >
> > ----------------------------------------------------------------------------
> >
> > -------------------------------------------------------------------
> >
> > I get
> >
> > Internal Server Error
> >
> > The server encountered an internal error or misconfiguration and was
> > unable
> > to complete your request.
> >
> > Please contact the server administrator, xxxxx@xxxxx.com and inform them
> > of
> > the time the error occurred, and anything you might have done that may
> > have
> > caused the error.
> >
> > More information about this error may be available in the server error
> > log.
> >
> >
> > ----------------------------------------------------------------------------
> > -------------------------------------------------------------------
> > error.log
> > ======
> > [Sat Nov 26 00:16:34 2005] [error] [client 0.0.0.0] (OS 3)The system
> > cannot
> > find the path specified.  : couldn't create child process: 720003:
> > admin.pl
> > [Sat Nov 26 00:16:34 2005] [error] [client 0.0.0.0] (OS 3)The system
> > cannot
> > find the path specified.  : couldn't spawn child process:
> > E:/sql-ledger/admin.pl
> >
> > ----------------------------------------------------------------------------
> >
> > -------------------------------------------------------------------
> >
> >
> > ---------------------------------------------------------------------
> > The official User-To-User support forum of the Apache HTTP Server
> > Project.
> > See <URL:http://httpd.apache.org/userslist.html> for more info.
> > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> >    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> > For additional commands, e-mail: users-help@httpd.apache.org
> >
> >
>

Mime
View raw message