httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jsl...@gmail.com>
Subject Re: [users@httpd] apache 1.3.33 multiple instances problem
Date Tue, 22 Nov 2005 16:22:57 GMT
On 11/22/05, Ken Murach <ken_murach@harvard.edu> wrote:
> Hi everyone,
>
> My name is Ken Murach and I'm relatively new to the apache world. I'm a
> unix administrator and I was recently asked to install apache 1.3.33 on one
> of our servers. I was able to install/configure apache 1.3.33 successfully.
> However, the user itisgrp is unable to start apache 1.3.33 for either the
> able or fad account. However, I am able as root to start up apache 1.3.33
> for both able & fad and have 2 instances running simultaneously.
>
> Can't figure out why I can get this to work for root, but not as the
> non-root user itisgrp. I verified that able will be using port 10061 and
> fad will be using port 10055. I also verified that the script which calls
> the httpd binary for each uses the -f flag to specify different configs.
>
> I've also verified that the User directive for each config file specifies
> the itisgrp account and the Group directive specifies the itis group.

The User and Group directive will be ignored if you aren't root when
you start the server.

Do you get any error message when you start as non-root?  Are the log
directories writable by the non-root user?  Have you tried running
under strace (or equivalent) to catch failing syscalls?

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message