httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jsl...@gmail.com>
Subject Re: [users@httpd] Problem with AuthPAM_Enabled' error in Apache2
Date Wed, 09 Nov 2005 22:01:24 GMT
On 11/9/05, Mick England <micke@ameritech.net> wrote:

>
> In the error logs I see the following:
>
> [Wed Nov 09 15:03:51 2005] [alert] [client 69.212.211.252] /.htaccess:
> Invalid command 'AuthPAM_Enabled', perhaps mis-spelled or defined by a
> module not included in the server configuration

So what exactly is in the .htaccess file?  That is your problem.

>
> My VirtualHost file contains the following: [Domain name hidden]
>
> NameVirtualHost *
> <VirtualHost my.domain.org>
> ServerAdmin mick@domain.org
> DocumentRoot /home/hosts/test
> ErrorLog /var/log/apache2/my.domain.org-error.log
> CustomLog /home/test/log/my.domain.org-access.log common
> <Directory /home/hosts/test>
> Order allow,deny
> Allow from all
> </Directory>
> </VirtualHost>

This probably isn't relevant, but that is a bad config.  If you are
doing name-based virtual hosting, that should be <VirtualHost *> and
you need a ServerName directive.  See the name-based virtual hosting
docs.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message