httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jsl...@gmail.com>
Subject Re: [users@httpd] httpd2 + tomcat5.5.9 problem with mod_rewrite
Date Tue, 08 Nov 2005 20:44:32 GMT
On 11/8/05, Peter.Neu@gmx.net <Peter.Neu@gmx.net> wrote:
> Hello,
>
> I' using mod_jk to connect tomcat to httpd2. This works perfectly. Now I try
> to manipulate the URL's which I map to httpd from tomcat. But the rules seem
> not to affect the response I get. Does this not work or am I doing something
> wrong.
>
> I my httpd config I have this entry:
>
> <directory ="/">
> LoadModule rewrite_module /usr/lib/apache2/mod_rewrite.so
> RewriteEngine on
> RewriteRule ^tricky.html$ post.html
> </directory>

I know next to nothing about mod_jk, but this is way off.  There
certainly shouldn't be an "=" sign in the <Directory> block.  The
LoadModule directive should not be inside a <Directory> block.  The
RewriteRule appears to be relative to the root directory of the
filesystem.  I could go on.

At minimum, you will surely want to use the RewriteLog to figure out
what mod_rewrite is actually seeing.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message