httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Avila" <Michael.Avil...@sbcglobal.net>
Subject [users@httpd] Cannot Get PERL to work
Date Sat, 26 Nov 2005 05:23:17 GMT
Windows XP Pro
Active State PERL 5.6 (Have to have 5.6 and not 5.8 for a specific
application)
NOTE: IP Addresses and website changed to prevent hacking


QUESTION: What is it that cannot be found - admin.pl or PERL.exe or
something else? 

----------------------------------------------------------------------------
-------------------------------------------------------------------
httpd.conf
=======
ScriptAlias /perl "d:/perl"
AddType application/x-httpd-pl .pl .cgi
Action application/x-httpd-pl "/perl/bin/perl.exe "


Alias /sql-ledger /sql-ledger
<Directory /sql-ledger>
AllowOverride All
AddHandler cgi-script .pl
AddDefaultCharset On
Options ExecCGI Includes FollowSymlinks
Order Allow,Deny
Allow from All
</Directory>

----------------------------------------------------------------------------
-------------------------------------------------------------------

when I execute a perl script from a web browser such as

http://www.xxxxx.com/sql-ledger/admin.pl

----------------------------------------------------------------------------
-------------------------------------------------------------------

I get

Internal Server Error

The server encountered an internal error or misconfiguration and was unable
to complete your request.

Please contact the server administrator, xxxxx@xxxxx.com and inform them of
the time the error occurred, and anything you might have done that may have
caused the error.

More information about this error may be available in the server error log.

----------------------------------------------------------------------------
-------------------------------------------------------------------
error.log
======
[Sat Nov 26 00:16:34 2005] [error] [client 0.0.0.0] (OS 3)The system cannot
find the path specified.  : couldn't create child process: 720003: admin.pl
[Sat Nov 26 00:16:34 2005] [error] [client 0.0.0.0] (OS 3)The system cannot
find the path specified.  : couldn't spawn child process:
E:/sql-ledger/admin.pl

----------------------------------------------------------------------------
-------------------------------------------------------------------


Mime
View raw message