httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kes Morland (A83066) Cobblers Hall Surgery DL5 4SE" <Kes.Morl...@gp-A83066.nhs.uk>
Subject FW: [users@httpd] Proxy set-up problem Urgent
Date Mon, 07 Nov 2005 11:15:12 GMT
Thanks Joshua;

I have increased the 'CacheSize 1024256' as this was originally lifted out
of the examples in the apache docs set as 256.  (MB?or bytes needs to be a
little more clearer in these docs..)

And I have set LogLevel to debug.

I have commented out the memory cache, so this should now cache to disk?

To test the proxy, I have created a proxytest.htm page containing one image.

The html source is:-
[html code]
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
	<head>
		<title>Proxy Test</title>
		<meta name="GENERATOR" content="Microsoft Visual Studio .NET
7.1">
		<meta name="vs_targetSchema"
content="http://schemas.microsoft.com/intellisense/ie5">
	</head>
	<body>
		<P>Testing Apache Proxy Cache</P>
		<P><IMG style="WIDTH: 416px; HEIGHT: 88px" height="88"
alt="Asprin Gif" src="images\aspirin_a.gif"
				width="416" align="middle"></P>
	</body>
</html>
[\html code]
On the server, I have set expiration up to 1 hour.

The page loads ok, but nothing seems to be cached.

The access log:-
[Access Log]
machine.domain.local - - [07/Nov/2005:10:57:57 +0000] "GET
http://jmg-net/proxytest.htm HTTP/1.0" 200 495
machine.domain.local - - [07/Nov/2005:10:57:57 +0000] "GET
http://jmg-net/images/aspirin_a.gif HTTP/1.0" 200 47214
[\Access Log]

And in the Error logs, there are no errors/warnings etc. only the following
debug messages: 

[Error Logs]
[Mon Nov 07 10:57:00 2005] [debug] proxy_http.c(67): proxy: HTTP:
canonicalising URL //jmg-net/proxytest.htm
[Mon Nov 07 10:57:00 2005] [debug] mod_proxy.c(418): Trying to run
scheme_handler
[Mon Nov 07 10:57:00 2005] [debug] proxy_http.c(1059): proxy: HTTP: serving
URL http://jmg-net/proxytest.htm
[Mon Nov 07 10:57:00 2005] [debug] proxy_http.c(186): proxy: HTTP connecting
http://jmg-net/proxytest.htm to jmg-net:80
[Mon Nov 07 10:57:00 2005] [debug] proxy_util.c(1139): proxy: HTTP: fam 2
socket created to connect to jmg-net
[Mon Nov 07 10:57:00 2005] [debug] proxy_http.c(336): proxy: socket is
connected
[Mon Nov 07 10:57:00 2005] [debug] proxy_http.c(370): proxy: connection
complete to 172.17.1.180:80 (jmg-net)
[Mon Nov 07 10:57:00 2005] [debug] proxy_http.c(893): proxy: start body send
[Mon Nov 07 10:57:00 2005] [debug] proxy_http.c(953): proxy: end body send
[Mon Nov 07 10:57:00 2005] [debug] proxy_http.c(67): proxy: HTTP:
canonicalising URL //jmg-net/images/aspirin_a.gif
[Mon Nov 07 10:57:00 2005] [debug] mod_proxy.c(418): Trying to run
scheme_handler
[Mon Nov 07 10:57:00 2005] [debug] proxy_http.c(1059): proxy: HTTP: serving
URL http://jmg-net/images/aspirin_a.gif
[Mon Nov 07 10:57:00 2005] [debug] proxy_http.c(186): proxy: HTTP connecting
http://jmg-net/images/aspirin_a.gif to jmg-net:80
[Mon Nov 07 10:57:00 2005] [debug] proxy_util.c(1139): proxy: HTTP: fam 2
socket created to connect to jmg-net
[Mon Nov 07 10:57:00 2005] [debug] proxy_http.c(336): proxy: socket is
connected
[Mon Nov 07 10:57:00 2005] [debug] proxy_http.c(370): proxy: connection
complete to 172.17.1.180:80 (jmg-net)
[Mon Nov 07 10:57:00 2005] [debug] proxy_http.c(893): proxy: start body send
[Mon Nov 07 10:57:00 2005] [debug] proxy_http.c(953): proxy: end body send
[\Error Logs]

Any ideas on what I am missing?

TIA
Kes

-----Original Message-----
From: Joshua Slive [mailto:jslive@gmail.com] 
Sent: 04 November 2005 15:15
To: users@httpd.apache.org
Subject: Re: [users@httpd] Proxy set-up problem Urgent

On 11/4/05, Kes Morland (A83066) Cobblers Hall Surgery DL5 4SE
<Kes.Morland@gp-a83066.nhs.uk> wrote:

>                         CacheSize 256

Gosh, that's small.  I think you want a much larger number here.

And make sure to set LogLevel to debug to get interesting stuff about
caching in the error log.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message