httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Susan Roesner RZ <sroe0...@rz.uni-hildesheim.de>
Subject [users@httpd] apache2/mod_ssl
Date Wed, 09 Nov 2005 11:59:51 GMT
Hello List,

I am using Solaris 10, apache 2.0.55 and openssl 0.9.7i to compile apache with 
mod_ssl and mod_so using the following commands
./configure --prefix=/path/to/apache --with-ssl=/opt/web/ssl097i --enable-ss
l --enable-rewrite --enable-so

The compilation/install proccess was fine. After the installation I looked into 
the modules folder - no ssl module installed. Also no entries in http.conf for 
ssl.

So I looked into config.log. There I found the only error messages concerning 
ssl - I guess it is the reason why no mod_ssl was installed. Unfortunately I 
cannot interpret the following error messages nor find something in google. 
Maybe someone can point me into the right direction.
entries in config.log:
configure:10590: checking whether to enable mod_ssl
configure:10626: result: checking dependencies
configure:10631: checking for SSL/TLS toolkit base
configure:10682: result: /opt/web/ssl097i
configure:10685: checking for SSL/TLS toolkit version
configure:10687: result: OpenSSL 0.9.7d 17 Mar 2004
configure:10705: checking for SSL/TLS toolkit includes
configure:10723: result: /opt/web/ssl097i/include
configure:10726: checking for SSL/TLS toolkit libraries
configure:10741: result: /opt/web/ssl097i/lib
configure:10909: checking for SSL_set_state
configure:10966: gcc -o conftest -O2  -DSOLARIS2=10 -D_POSIX_PTHREAD_SEMANTICS -
D_REENTRANT   -L/opt/src/httpd-2.0.55/srclib/apr-util/xml/expat/lib -L/opt/web/s
sl097i/lib -R/opt/web/ssl097i/lib conftest.c -lssl -lcrypto >&5
Undefined                       first referenced
 symbol                             in file
SSL_set_state                       /var/tmp//ccoHQKcX.o
ld: fatal: Symbol referencing errors. No output written to conftest
collect2: ld returned 1 exit status
configure:10972: $? = 1
configure: failed program was:
| /* confdefs.h.  */
<...>
configure:10997: result: no
configure:11011: checking for SSL_set_cert_store
configure:11068: gcc -o conftest -O2  -DSOLARIS2=10 -D_POSIX_PTHREAD_SEMANTICS -
D_REENTRANT   -L/opt/src/httpd-2.0.55/srclib/apr-util/xml/expat/lib -L/opt/web/s
sl097i/lib -R/opt/web/ssl097i/lib conftest.c -lssl -lcrypto >&5
Undefined                       first referenced
 symbol                             in file
SSL_set_cert_store                  /var/tmp//ccELGIQo.o
ld: fatal: Symbol referencing errors. No output written to conftest
collect2: ld returned 1 exit status
configure:11074: $? = 1
configure: failed program was:
| /* confdefs.h.  */
<...>
configure:11099: result: no
configure:11110: checking whether to enable mod_ssl
configure:11122: result: yes (default)


Susan


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message