httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joost de Heer" <sang...@xs4all.nl>
Subject [users@httpd] mod_proxy_html question
Date Fri, 25 Nov 2005 08:22:56 GMT
Hello,

I have a mod_proxy_html question:

Software used:

- Red Hat Enterprise Linux AS release 3 (Taroon Update 6)
- httpd-2.1.9 (because I need mod_proxy_balancer)
- mod_proxy_html 2.5

I use the following configuration for a reverse proxy vhost:

<VirtualHost *:443>
  SSLEngine on
  ServerName XXX.YYY.ZZZ

  SSLCertificateFile conf/ssl/cert.cer
  SSLCertificateKeyFile conf/ssl/cert.key

  ProxyPass /token http://172.28.0.8:81/tmsweb
  ProxyPassReverse /token http://172.28.0.8:81/tmsweb

  <Location /token>
    ProxyPassReverse /
    SetOutputFilter proxy-html
    ProxyHTMLURLMap /tmsweb /token
    ProxyHTMLFixups lowercase
    ProxyHTMLExtended On
  </Location>

  ProxyPass /webmail balancer://webmailcluster
  ProxyPassReverse /webmail http://172.28.0.15
  ProxyPassReverse /webmail http://172.28.0.16
  <Location /webmail>
    ProxyPassReverse /
    SetOutputFilter proxy-html
    ProxyHTMLURLMap / /webmail/
    ProxyHTMLURLMap /webmail/ /webmail/
    ProxyHTMLFixups lowercase
    ProxyHTMLExtended On
    ProxyHTMLLogVerbose on
  </Location>

  <Proxy balancer://webmailcluster>
    BalancerMember http://172.28.0.15
    BalancerMember http://172.28.0.16
  </Proxy>

  ErrorLog "| /opt/vw/apache/2.1.9/bin/rotatelogs
/opt/vw/apache/2.1.9/logs/443/error_%Y%m%d.log 86400"
  CustomLog "| /opt/vw/apache/2.1.9/bin/rotatelogs
/opt/vw/apache/2.1.9/logs/443/access_%Y%m%d.log 86400" common

  <Location /balancer-manager>
    SetHandler balancer-manager

    Order allow,deny
    Allow from 172.28.0
  </Location>
</VirtualHost>

The token server works as expected. Links are getting rewritten, and the
site works fine. However, the webmail location has a problem: If I disable
the output filter, the content isn't changed (of course), but if I enable
the filter, I get the following error:

curl -i -k -u "user:pwd" https://localhost/webmail/
curl: (52) Empty reply from server

I see in the main server config the following:

[Thu Nov 24 16:45:12 2005] [notice] child pid 15017 exit signal
Segmentation fault (11)

I enabled coredumping, and if I run gdb on the coredump, I get the
following trace:

gdb ../bin/httpd core.15930
GNU gdb Red Hat Linux (6.3.0.0-1.62rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host
libthread_db library "/lib/tls/libthread_db.so.1".

Core was generated by `/opt/vw/apache/2.1.9/bin/httpd -k start'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/tls/libm.so.6...done.
Loaded symbols for /lib/tls/libm.so.6
Reading symbols from /opt/vw/apache/2.1.9/lib/libaprutil-1.so.0...done.
Loaded symbols for /opt/vw/apache/2.1.9/lib/libaprutil-1.so.0
Reading symbols from /usr/lib/libgdbm.so.2...done.
Loaded symbols for /usr/lib/libgdbm.so.2
Reading symbols from /lib/libdb-4.1.so...done.
Loaded symbols for /lib/libdb-4.1.so
Reading symbols from /usr/lib/libexpat.so.0...done.
Loaded symbols for /usr/lib/libexpat.so.0
Reading symbols from /opt/vw/apache/2.1.9/lib/libapr-1.so.0...done.
Loaded symbols for /opt/vw/apache/2.1.9/lib/libapr-1.so.0
Reading symbols from /lib/libuuid.so.1...done.
Loaded symbols for /lib/libuuid.so.1
Reading symbols from /lib/tls/librt.so.1...done.
Loaded symbols for /lib/tls/librt.so.1
Reading symbols from /lib/libcrypt.so.1...done.
Loaded symbols for /lib/libcrypt.so.1
Reading symbols from /lib/tls/libpthread.so.0...done.
Loaded symbols for /lib/tls/libpthread.so.0
Reading symbols from /lib/libdl.so.2...done.
Loaded symbols for /lib/libdl.so.2
Reading symbols from /lib/tls/libc.so.6...done.
Loaded symbols for /lib/tls/libc.so.6
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
Reading symbols from /lib/libnss_files.so.2...done.
Loaded symbols for /lib/libnss_files.so.2
Reading symbols from /opt/vw/apache/2.1.9/modules/mod_authz_host.so...done.
Loaded symbols for /opt/vw/apache/2.1.9/modules/mod_authz_host.so
Reading symbols from /opt/vw/apache/2.1.9/modules/mod_proxy.so...done.
Loaded symbols for /opt/vw/apache/2.1.9/modules/mod_proxy.so
Reading symbols from
/opt/vw/apache/2.1.9/modules/mod_proxy_balancer.so...done.
Loaded symbols for /opt/vw/apache/2.1.9/modules/mod_proxy_balancer.so
Reading symbols from /opt/vw/apache/2.1.9/modules/mod_proxy_http.so...done.
Loaded symbols for /opt/vw/apache/2.1.9/modules/mod_proxy_http.so
Reading symbols from /opt/vw/apache/2.1.9/modules/mod_ssl.so...done.
Loaded symbols for /opt/vw/apache/2.1.9/modules/mod_ssl.so
Reading symbols from /lib/libssl.so.4...done.
Loaded symbols for /lib/libssl.so.4
Reading symbols from /lib/libcrypto.so.4...done.
Loaded symbols for /lib/libcrypto.so.4
Reading symbols from /usr/kerberos/lib/libgssapi_krb5.so.2...done.
Loaded symbols for /usr/kerberos/lib/libgssapi_krb5.so.2
Reading symbols from /usr/kerberos/lib/libkrb5.so.3...done.
Loaded symbols for /usr/kerberos/lib/libkrb5.so.3
Reading symbols from /usr/kerberos/lib/libcom_err.so.3...done.
Loaded symbols for /usr/kerberos/lib/libcom_err.so.3
Reading symbols from /usr/kerberos/lib/libk5crypto.so.3...done.
Loaded symbols for /usr/kerberos/lib/libk5crypto.so.3
Reading symbols from /lib/libresolv.so.2...done.
Loaded symbols for /lib/libresolv.so.2
Reading symbols from /usr/lib/libz.so.1...done.
Loaded symbols for /usr/lib/libz.so.1
Reading symbols from /opt/vw/apache/2.1.9/modules/mod_log_config.so...done.
Loaded symbols for /opt/vw/apache/2.1.9/modules/mod_log_config.so
Reading symbols from /opt/vw/apache/2.1.9/modules/mod_alias.so...done.
Loaded symbols for /opt/vw/apache/2.1.9/modules/mod_alias.so
Reading symbols from /usr/lib/libxml2.so...done.
Loaded symbols for /usr/lib/libxml2.so
Reading symbols from /opt/vw/apache/2.1.9/modules/mod_proxy_html.so...done.
Loaded symbols for /opt/vw/apache/2.1.9/modules/mod_proxy_html.so
Reading symbols from /opt/vw/apache/2.1.9/modules/mod_status.so...done.
Loaded symbols for /opt/vw/apache/2.1.9/modules/mod_status.so
#0  0x00f623ca in proxy_html_filter (f=0xa0107e8, bb=0xa00e8a8) at
mod_proxy_html.c:826
826     mod_proxy_html.c: No such file or directory.
        in mod_proxy_html.c
(gdb) bt
#0  0x00f623ca in proxy_html_filter (f=0xa0107e8, bb=0xa00e8a8) at
mod_proxy_html.c:826
#1  0x080795f2 in ap_pass_brigade (next=0x0, bb=0x5) at util_filter.c:526
#2  0x00888d67 in ap_proxy_http_process_response (p=0xa0028e8,
r=0xa00f0b0, backend=0x9f540f8, origin=0xa00e1a0, conf=0x9f570f8,
    server_portstr=0xbfffb180 "") at mod_proxy_http.c:1470
#3  0x0088962f in proxy_http_handler (r=0xa00f0b0, worker=0x9fb6008,
conf=0x9f570f8, url=0xa00e198 "/", proxyname=0x0, proxyport=0)
    at mod_proxy_http.c:1715
#4  0x00f8ca9f in proxy_run_scheme_handler (r=0xa00f0b0, worker=0x9fb6008,
conf=0x9f570f8, url=0xa010850 "http://172.28.0.15/", proxyhost=0x0,
    proxyport=5) at mod_proxy.c:1941
#5  0x00f8a6ad in proxy_handler (r=0xa00f0b0) at mod_proxy.c:739
#6  0x0807143e in ap_run_handler (r=0xa00f0b0) at config.c:158
#7  0x08071956 in ap_invoke_handler (r=0xa00f0b0) at config.c:371
#8  0x0807b92b in ap_process_request (r=0xa00f0b0) at http_request.c:258
#9  0x08079a75 in ap_process_http_connection (c=0xa002ab8) at http_core.c:171
#10 0x080769f6 in ap_run_process_connection (c=0xa002ab8) at connection.c:43
#11 0x0807f5ca in child_main (child_num_arg=0) at prefork.c:640
#12 0x0807f733 in make_child (s=0x9f4fd88, slot=1) at prefork.c:736
#13 0x0807f7cf in startup_children (number_to_start=4) at prefork.c:754
#14 0x080800ff in ap_mpm_run (_pconf=0x9f4e0a8, plog=0x9f7c160,
s=0x9f4fd88) at prefork.c:975
#15 0x08061df4 in main (argc=3, argv=0xbfffb554) at main.c:712

Server compiled with:
--prefix=/opt/vw/apache/2.1.9 --enable-proxy --enable-proxy-balancer
--enable-proxy-http --enable-rewrite --enable-mods-shared=most
--enable-headers --enable-ssl

In mod_proxy_html.c I've added a #define USE_OLD_LIBXML2, since this
machine comes with libxml2 2.5.10-7. Because of these additions, the
default line numbers of mod_proxy_html.c aren't valid anymore. Line
824-828 in the modified mod_proxy_html.c are:

824:              == APR_SUCCESS ) {
825:      if ( ctxt->parser == NULL ) {
826:        if ( buf[bytes] != 0 ) {
827:          /* make a string for parse routines to play with */
828:          char* buf1 = apr_palloc(f->r->pool, bytes+1) ;

I've tried using ProxyPass /webmail http://172.28.0.15 (to see if it was a
balancer problem) and got the same error.

Anyone sees what


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message