httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kjell Grindalen" <kjell.grinda...@sio.no>
Subject [users@httpd] High cpu load on apache
Date Tue, 22 Nov 2005 14:17:42 GMT
Hi everyone!

I am runninng apache-2.0.55 on a Solaris 9 SPARC server.
I use the server a a frontend for my websphere 5.1 server
My configure looks like this

./configure --prefix=/usr/local/apache_prod --with-mpm=prefork
--enable-info --enable-so --enable-rewrite --enable-proxy
--enable-static-rotatelogs

My problem is that after a while, some requests makes one or sometimes
more, of my httpd servers hit the roof cpu-wise.
And it stays there til I kille the process.

I have tried to apply the following patch, with no success

Ohttp://people.apache.org/~wrowe/httpd-2.0-proto-timeout.patch


A truss on the process only gives what you can see down below.


brk(0x005C2D98)                                 = 0
brk(0x005C4D98)                                 = 0
brk(0x005C4D98)                                 = 0
brk(0x005C6D98)                                 = 0
brk(0x005C6D98)                                 = 0
brk(0x005C8D98)                                 = 0
brk(0x005C8D98)                                 = 0
brk(0x005CAD98)                                 = 0
brk(0x005CAD98)                                 = 0
brk(0x005CCD98)                                 = 0
brk(0x005CCD98)                                 = 0
brk(0x005CED98)                                 = 0
brk(0x005CED98)                                 = 0
brk(0x005D0D98)                                 = 0
brk(0x005D0D98)                                 = 0
brk(0x005D2D98)                                 = 0
brk(0x005D2D98)                                 = 0
brk(0x005D4D98)                                 = 0
brk(0x005D4D98)                                 = 0
brk(0x005D6D98)                                 = 0
brk(0x005D6D98)                                 = 0
brk(0x005D8D98)                                 = 0
brk(0x005D8D98)                                 = 0
brk(0x005DAD98)                                 = 0
brk(0x005DAD98)                                 = 0
brk(0x005DCD98)                                 = 0
brk(0x005DCD98)                                 = 0
brk(0x005DED98)                                 = 0
brk(0x005DED98)                                 = 0
brk(0x005E0D98)                                 = 0
brk(0x005E0D98)                                 = 0

Anyone have an idea what is wrong?


Mvh

Kjell Grindalen


This e-mail and any attachments may contain confidential and
privileged information. If you are not the intended recipient,
please notify the sender immediately by return e-mail, delete this
e-mail and destroy any copies. Any dissemination or use of this
information by a person other than the intended recipient is
unauthorized and may be illegal.
Mime
View raw message