httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jsl...@gmail.com>
Subject Re: [users@httpd] No Luck wuth VirtualHosts
Date Thu, 06 Oct 2005 23:26:57 GMT
On 10/6/05, Nick Jones <nickj6282@yahoo.com> wrote:
> > Both myDomain.com and test.myDomain.com point to the
> > IP address of my cable
> > modem. (They have real names I'm not showing here.)
> >
> > >Are you restarting the server after every change?
> >
> > Yes.
> >
> > Ken
>
> Ken,
>
> Try adding a "ServerAlias" directive to each of your
> vhost containers. So add:
>
> ServerAlias MyDomain.com (to the MyDomain vhost)
> ServerAlias test.MyDomain.com (to the test vhost)
>
> Then restart apache and see if that helps.

No, that shouldn't be necessary.

The most likely cause of this is that the cable modem is stripping (or
rewriting) the Host header and not simply forwarding packets.  That
means that apache doesn't have the information to do name-based
virtual hosting.  You can confirm that by logging the Host header in
the access log.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message