httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Kogut <jmko...@gmail.com>
Subject Re: [users@httpd] Subject: Problem loading PHP module in Apache 2.1.8
Date Sun, 09 Oct 2005 15:36:07 GMT
I think that there is possibly an issue dealing with the newer version of
apache, and the older version of the php module. Try running it in cgi mode
instead. See if that works.

On 10/5/05, Uzo Madujibeya <uzomadu@gmail.com> wrote:
>
> Hi,
> I have just upgraded to Apache 2.1.8 on OS X 10.4.2 and am having a
> problem trying to load php. At the bottom of my httpd.conf file I
> specify the following:
>
> # PHP4 configuration
> LoadModule php4_module modules/libphp4.so
> AddType application/x-httpd-php .php .phtml
> AddType application/x-httpd-php-source .phps
>
> and the libphp4.so module is located as specified, in the modules
> folder, but when i try to start or shutdown Apache I get the
> following error message:
>
>
> httpd: Syntax error on line 444 of /usr/local/apache2/conf/
> httpd.conf: Cannot load /usr/local/apache2/modules/libphp4.so into
> server: Library not loaded: /Library/Apache2/lib/libaprutil-0.0.dylib
> \n Referenced from: /usr/local/apache2/modules/libphp4.so\n Reason:
> image not found
>
>
> What is the issue here?
>
> beya
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> " from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>


--
|| jmkogut ||
email: jmkogut@gmail.com

Mime
View raw message