httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Krist van Besien <krist.vanbes...@gmail.com>
Subject Re: [users@httpd] No Luck wuth VirtualHosts
Date Fri, 07 Oct 2005 15:27:33 GMT
On 10/7/05, kloomis <kloomis@it-resources.com> wrote:
>  At 01:09 PM 10/7/2005 +0200, you wrote:
>
> >  OK, now the initial page is opening at the right directory, but all the
>  > follow on links are reverting to only one directory.  Could this be an
>  > Apache problem or is it my configs for the application I'm using?
>
>  That will probably be the application. Often you need to configure
>  somewhere what the base URL is that it is being served from.
>  Do the pages contain relative or absolute links?
>  Yes, I do configure the base URLs, and I have set them up for each
> directory, but one keeps getting precedence.  The links are resolving to
> absolute URLs.  Could this be a mod-rewrite issue?

mod-rewrite does not touch anything going from your server to your
client. If your clients get webpages with the wrong absolute url's in
them, than this is because the webpages contain these absolute URLs,
or the application generating the webpages generates these URLs.

Krist
--
krist.vanbesien@gmail.com
Solothurn, Switzerland

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message