httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jay Allen" <Jay.Al...@mail.wvu.edu>
Subject [users@httpd] Parent: child process exited with status 3221226324 -- Restarting.
Date Tue, 20 Sep 2005 17:59:13 GMT
I could use some help!

I am running apache 2.0.49 on w2k3 server w/mod_ssl and CFMX 6.1 std.

apache is intermittently throwing this in the error.log:

Parent: child process exited with status 3221226324 -- Restarting.

...followed by what looks like the normal apache startup routine each
time.

I also see a corresponding error noted each time on the server console
(in the box to send/don't send the report to MS).  The console error
states that apache ecountered errors and needed to restart, and the
detailed view just lists modname libapr.dll.

Each time this happens, Apache becomes nonresponsive, and the restart
command will not work.  The stop command appears to work, but then when
I try to start apache again, it complains that only 1 connection to a
port is permitted and notes that port 443 is already connected.  In the
past I have reverted to rebooting the server to get apache to start
agian, however I recently found that I can track down the rogue process
via a utility called active ports, and then I can terminate the
remaining apache process there manually.  Once I do that, I can start
apache.

Once apache is started it will operate ok for an inconsistent amount of
time; sometimes a couple of hours, sometimes 10 days or more.  I can't
seem to find any other evidence pointing to what the issue might be.

I'd appreciate any input or advice you folks could offer.  What should
I check next? Is there a known fix for this issue out there somewhere? 
I saw several messages about this on various discussion boards (bugtraq,
macromedia, etc.) but I can't find any solution there, or even any
indication that it's the same cause in any cases.  I'm sure you guys
hear this a lot, but I'm at my wits end with this issue and I could
really use some help and or advice.

Also please let me know if you need to see my apache conf files or
extended log entries etc. and I can provide those if necessary.

Thank You,

Jay J. Allen <jjallen@mail.wvu.edu>
Professional Technologist
WVU Web Services
ph: (304) 293-5276
fax: (304) 293-7414

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message