httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Wills <mishy....@gmail.com>
Subject [users@httpd] Really annoying problem either with Apache2 or PHP or both
Date Sat, 10 Sep 2005 12:59:08 GMT
Hi,

I am having a really bad time with apache 2 and have been for months now. I 
have tried everything I can think of to 

rectify this and its just not working.

I am having gigantic 30second page load pauses with Apache2. These appear to 
be random but its hard to tell if 

there is a specific cause as my server is quite busy. Users complain, and it 
drives me absolutely crazy.

The only thing I can see in my error_log that coincides with these incidents 
is this:

[Sat Sep 10 04:39:00 2005] [info] (104)Connection reset by peer: 
core_output_filter: writing data to the network
[Sat Sep 10 04:39:00 2005] [info] (32)Broken pipe: core_output_filter: 
writing data to the network

I don't know if this is a clue or not but there also seems to be 404s around 
the same time as those errors pop up 

^^

I get hundreds if not thousands of those per day. This is not someone just 
hitting stop of their browser. That 

explanation does not fit the sheer number of occurances at all. Again, I 
would like to reiterate that this has been 

going on for months.

Can anyone help me please - its getting to the stage where I am just going 
to switch from apache to another 

webserver or downgrade to 1.3.

Thanks for any offers of help - I really am getting so frustrated.



What I have tried:

i) Removing completely unnecessary modules
ii) Tried removing necessary modules one by one to see if that improved the 
issues.
iii) Upgraded from PHP 4.4.0 to PHP5.0.5
iv) Disabled my firewall
v) Disabled mod_security
vi) Asked at my data centre to see if they had a problem on their end with 
either my server or its connection to 

their backbones
vii) Removed eaccelerator
viii) Removed Zend Optimizer

This is my module section of httpd.conf

LoadModule access_module modules/mod_access.so
LoadModule auth_module modules/mod_auth.so
#LoadModule auth_dbm_module modules/mod_auth_dbm.so
#LoadModule auth_digest_module modules/mod_auth_digest.so
#LoadModule file_cache_module modules/mod_file_cache.so
LoadModule include_module modules/mod_include.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule env_module modules/mod_env.so
#LoadModule mime_magic_module modules/mod_mime_magic.so
#LoadModule cern_meta_module modules/mod_cern_meta.so
#LoadModule expires_module modules/mod_expires.so
#LoadModule headers_module modules/mod_headers.so
#LoadModule usertrack_module modules/mod_usertrack.so
#LoadModule unique_id_module modules/mod_unique_id.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule ssl_module modules/mod_ssl.so
LoadModule mime_module modules/mod_mime.so
#LoadModule dav_module modules/mod_dav.so
LoadModule autoindex_module modules/mod_autoindex.so
#LoadModule cgi_module modules/mod_cgi.so
#LoadModule dav_fs_module modules/mod_dav_fs.so
#LoadModule vhost_alias_module modules/mod_vhost_alias.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule dir_module modules/mod_dir.so
#LoadModule actions_module modules/mod_actions.so
#LoadModule speling_module modules/mod_speling.so
LoadModule alias_module modules/mod_alias.so
LoadModule rewrite_module modules/mod_rewrite.so
#LoadModule perl_module modules/mod_perl.so
LoadModule security_module /usr/lib/httpd/modules/mod_security.so
#LoadModule php4_module /usr/lib/httpd/modules/libphp4.so
LoadModule php5_module /usr/lib/httpd/modules/libphp5.so

My configure line:

export CFLAGS="-O2 -march=i686 -funroll-loops -D_REENTRANT 
-D_SINGLE_LISTEN_UNSERIALIZED_ACCEPT -fPIC"
./configure --prefix=/etc/httpd \
--exec-prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
--mandir=/usr/share/man \
--sysconfdir=/etc/httpd/conf \
--includedir=/usr/include/httpd \
--libexecdir=/usr/lib/httpd/modules \
--datadir=/home/httpd \
--localstatedir=/var \
--with-mpm=prefork \
--enable-access=shared \
--enable-actions=shared \
--enable-alias=shared \
--enable-auth=shared \
--enable-auth-dbm=shared \
--enable-auth-digest=shared \
--enable-autoindex=shared \
--enable-cern-meta=shared \
--enable-cgi=shared \
--enable-cgid=shared \
--enable-dav=shared \
--enable-dav-fs=shared \
--enable-dir=shared \
--enable-env=shared \
--enable-expires=shared \
--enable-file-cache=shared \
--enable-headers=shared \
--enable-include=shared \
--enable-log-config=shared \
--enable-deflate \
--enable-mime=shared \
--enable-mime-magic=shared \
--enable-negotiation=shared \
--enable-rewrite=shared \
--enable-setenvif=shared \
--enable-speling=shared \
--enable-ssl=shared \
--enable-unique-id=shared \
--enable-usertrack=shared \
--enable-vhost-alias=shared \
--enable-suexec=shared \
--with-suexec-caller=www \
--with-suexec-docroot=/home/httpd \
--with-suexec-logfile=/var/log/httpd/suexec.log \
--with-suexec-bin=/usr/sbin/suexec \
--with-suexec-uidmin=500 --with-suexec-gidmin=500 \
--disable-auth-anon \
--disable-charset-lite \
--disable-disk-cache \
--disable-mem-cache \
--disable-cache \
--disable-ext-filter \
--disable-case-filter \
--disable-case-filter-in \
--disable-example \
--disable-proxy \
--disable-proxy-connect \
--disable-proxy-ftp \
--disable-proxy-http \
--disable-status \
--disable-asis \
--disable-info \
--disable-imap \
--disable-userdir \
--with-z \
--with-ssl \
--with-suexec

Mime
View raw message