httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mishra, Pawan" <Pawan.Mis...@FMR.COM>
Subject RE: [users@httpd] Httpd processes are not dying
Date Wed, 21 Sep 2005 06:11:56 GMT
Hi,

I have following output from the mod_status. It shows 16 processes.
Observe that only the five processes have PID's (MaxSpareServer is 5).
Do the other ones exist too in the memory? Is it a bug?

Srv PID Acc M  CPU  SS Req Conn Child Slot Client VHost Request  
0-0 111402 0/75/75 W_  10.99 0 0 0.0 0.28 0.28  10.32.6.13 myserver GET
/server-status HTTP/1.1 
1-0 94556 0/77/77 __  9.14 69 16 0.0 0.17 0.17  myserver  GET
/server-status HTTP/1.1 
2-0 84944 0/82/82 __  10.90 43 1 0.0 0.19 0.19  10.32.6.13 myserver GET
/oaa/images/error_logo.gif HTTP/1.1 
3-0 100506 0/71/71 __  9.40 31 0 0.0 0.16 0.16  10.32.6.13 myserver GET
/oaa/images/1pxGrey.gif HTTP/1.1 
4-0 71882 0/82/82 __  8.44 69 6 0.0 0.35 0.35  myserver  GET
/server-status HTTP/1.1 
5-0 - 0/0/17 ._  0.05 269 0 0.0 0.00 0.17  10.32.6.13 myserver GET
/oaa/images/go.gif HTTP/1.1 
6-0 - 0/0/29 ._  0.16 290 1 0.0 0.00 0.06  10.32.6.13 myserver GET
/oaa/images/spacer.gif HTTP/1.1 
7-0 - 0/0/30 ._  0.13 293 0 0.0 0.00 0.14  10.32.6.13 myserver GET
/oaa/images/go.gif HTTP/1.1 
8-0 - 0/0/17 ._  0.09 290 0 0.0 0.00 0.04  10.32.6.13 myserver GET
/oaa/images/1pxGrey.gif HTTP/1.1 
9-0 - 0/0/7 ._  0.04 320 0 0.0 0.00 0.00  10.32.6.13 myserver GET
/oaa/images/go.gif HTTP/1.1 
10-0 - 0/0/24 ._  0.15 297 1165 0.0 0.00 0.09  10.32.6.13 myserver GET
/oaa/js/fidelityscripts.js HTTP/1.1 
11-0 - 0/0/14 ._  0.06 303 0 0.0 0.00 0.00  10.32.6.13 myserver GET
/oaa/images/go.gif HTTP/1.1 
12-0 - 0/0/18 ._  0.08 297 0 0.0 0.00 0.11  10.32.6.13 myserver GET
/oaa/images/1pxGrey.gif HTTP/1.1 
13-0 - 0/0/18 ._  0.10 297 0 0.0 0.00 0.09  10.32.6.13 myserver GET
/oaa/images/go.gif HTTP/1.1 
14-0 - 0/0/12 ._  0.05 303 2 0.0 0.00 0.02  10.32.6.13 myserver GET
/oaa/js/setDomain.js HTTP/1.1 
15-0 - 0/0/1 ._  0.02 311 94 0.0 0.00 0.000  10.32.6.13 myserver GET
/oaa/js/setDomain.js HTTP/1.1 

-----Original Message-----
From: Mishra, Pawan 
Sent: Tuesday, September 13, 2005 10:58 PM
To: 'users@httpd.apache.org'
Subject: RE: [users@httpd] Httpd processes are not dying


Thanks. I have checked to see that there is no duplicate entry for
MaxSpareServers.

-----Original Message-----
From: Joshua Slive [mailto:jslive@gmail.com] 
Sent: Tuesday, September 13, 2005 10:52 PM
To: users@httpd.apache.org
Subject: Re: [users@httpd] Httpd processes are not dying


On 9/13/05, Mishra, Pawan <Pawan.Mishra@fmr.com> wrote:
> Hi Joshua,
> 
> I am not sure you remember the problem I stated last time so I am
> listing it here again. You had asked me to run mod_status. I have
> attached the output of the mod_status too.
> 
> Problem: The httpd processes keep getting accumulated in the memory
and
> are not dying timely as expected. This happens even when there is no
use
> of the application for hours. There are times when we see more that 70
> such processes even when application has not been used for 6-7 hours.
> Since these processes donot dye in timely manner, they keep getting
> accumulated till the MaxClient limit is reached and at that point
I.H.S.
> stops responding and thus site becomes down. We then need to restart
the
> I.H.S. server. We have been experiencing this problem since we
migrated
> to WAS 5.0.2 / I.H.S. 1.3.26.2 combination.

Well, the server-status looks completely normal except that
MaxSpareServers is not being honored.  So the first thing I'd do is
triple-check that you are editting the correct config-file, and that
MaxSpareServers occurs only once in that config.

Other than that, I'd really suggest reporting this to IBM, since it
appears you are using an IBM-modified version of the server.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server
Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message