httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jessica Rasku <jra...@armispiansystems.ca>
Subject Re: [users@httpd] httpd won't start
Date Wed, 28 Sep 2005 04:23:40 GMT
webmaster@chismtrail.com wrote:

> Following your sample, after setting the NameVirtualHost
> 
> # Use name-based virtual hosting.
> #
> NameVirtualHost 216.107.115.123:80
> 
> I made one site look like this:
> 
> # Virtual host evergreenequikits.com
> <VirtualHost *:80>
>        DocumentRoot /var/www/ginftp/evergreenequikits.com
> 
>        ServerAdmin webmaster@chismtrail.com
>        ServerName evergreenequikits.com
>        DirectoryIndex index.html index.htm index.shtml
>        ServerSignature email
>        CustomLog logs/access_log combined
>        ServerSignature email
> </VirtualHost>

I would make one recomendation here, put in a ServerAlias dirrective 
containing the value *.evergreenequikits.com.  That will allow you to 
access it as both www.evergreenequikits.com as well as 
evergreenequikits.com.  There may be reasons you don't want to do that, 
but it's generally recomended practice.

As for why it doesn't work, I would say it's because you probably want 
to set your NameVirtualHost to *:80.  Though there may be reasons that 
you don't want it as that.  I hope that this works.

							Jessica

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message