httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Terence Burnard <terenceburn...@knet.ca>
Subject [users@httpd] CGI wont read STDIN/POST
Date Tue, 27 Sep 2005 23:32:56 GMT
Hello,

I have been working for a while trying to get Nagios working with
apache.  This is the .htaccess configuration for the directory that the
cgis are in:

AuthName "Nagios Access"
AuthType Basic
#AuthScriptURI "/htlogin/ldap.php?filter=nagios"
require valid-user
AuthUserFile /home/nagios/nagios.users

Now if you notice, the AuthScriptURI is commented out. This is the the
configuration that works.

If I uncomment AuthScriptURI and comment out AuthUserFile, my browser
locks up on this line in the cgi:
      if(!fread(cgiinput,content_length,1,stdin)){
The cgi can retrieve CONTENT_LENGTH and CONTENT_TYPE from the environment.


Now the question I have is:

What configuration would prevent the cgi script from reading the POST
variables on STDIN when the script works fine with AuthUserFile but
hangs on a 'fread' with AuthScriptURI?

The ldap.php script works properly on GET requests, but as mentioned
hangs on POST.


Thanks,


Terence

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message