httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean Lee <jean....@free.fr>
Subject [users@httpd] error after installation on WINXP SP2 : [crit] (OS 10022) WSASocket failed to open the inherited socket
Date Thu, 15 Sep 2005 09:43:46 GMT
Hi all,

I'm new to the list and new to apache.
I tried to install Apache 2.0.54 but with no success.

The things I have done are :

Download "apache-2.0.54-no_ssl.exe" installer from the download site of 
apache. (I downloaded the .msi too but the windows installer does not 
recognize the file and I don't know why).

Well, the installation seems to be OK on  my computer (WinXP SP2) with 
the .exe installer BUT :

After the installation apache2 is started automatically as a service. I 
tried with mozilla to see the index page : http://127.0.0.1/ but there 
was no response.
When I looked to the error log file, I get a lot of error messages :

[Thu Sep 15 10:54:43 2005] [notice] Apache/2.0.54 (Win32) configured -- 
resuming normal operations
[Thu Sep 15 10:54:43 2005] [notice] Server built: Apr 16 2005 14:25:31
[Thu Sep 15 10:54:43 2005] [notice] Parent: Created child process 3220
[Thu Sep 15 10:54:43 2005] [notice] Child 3220: Child process is running
[Thu Sep 15 10:54:43 2005] [crit] (OS 10022) invalid argument  : Child 
3220: setup_inherited_listeners(), WSASocket failed to open the 
inherited socket.
[Thu Sep 15 10:54:44 2005] [error] Parent: child process exited with 
status 3 -- Aborting.

These messages are comming in loop.

I tried to search in Google and some people seemed to have the same 
problems. To fix it, they disabled either LMHOSTS or NETBIOS in their 
TCP/IP settings. I tried it but it doesn't work.

Does anybody experienced the problem and have a tip ?

Thank you for any help,

Jean LEE


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message