httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitriy Kirhlarov <dkirhla...@oilspace.com>
Subject Re: [users@httpd] Virt Host not Working under SSL
Date Tue, 20 Sep 2005 07:01:31 GMT
On Tue, Sep 20, 2005 at 08:39:02AM +0200, Krist van Besien wrote:
> On 9/20/05, Jason Beebe <jason@atalus.net> wrote:
> 
> > So what is so baffling to me is when accessing the domain via https:// it
> > does pull up the proper website, but Apache looks like it is defaulting to
> > the key/crt pair of the first entry.
> 
> >From the Apache SSL FAQ:

BUT!

I think it possible with some trics.
1. SSL certificate with more them 1 DNS-names. (see openssl.cnf for subjectAltNames)
2. Squid, installed in accelerator mode. SSL layer terminate on the Squid. Connection squid-apache
-- plain HTTP without SSL (may be, redirector, for example, jesred http://www.scn.rain.com/pub/network/www/
must be used).

Not very easy and need experiments, but I think it possible.

WBR
-- 
Dmitriy Kirhlarov
OILspace, 26 Leninskaya sloboda, bld. 2, 2nd floor, 115280 Moscow, Russia
P:+7 095 105 7247 F:+7 095 105 7246 E:DmitriyKirhlarov@oilspace.com
OILspace - The resource enriched - www.oilspace.com

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message