httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oscar Haeger <Oscar.Hae...@nbit.sigma.se>
Subject [users@httpd] SuExec and symlinks
Date Mon, 19 Sep 2005 12:36:01 GMT
Hi.
First I'd like to apologize if this question has been asked before, but I've
scanned the archives and haven't found anything about it.

What I'd like to know is if SuExec somehow prevents me from running scripts via
symlinks.
I have a webserver with SuExec installed and I'd like to be able to run scripts
that resides in other peoples cgi-bin directories. I've tested this but haven't
been able to get it to work. The httpd.conf is set to "FollowSymLinks" wherever
applicable and it does so when pointed to a normal html-page but not when it
comes to cgi's.
In the suexec-log I get this error-msg:
[2005-09-19 09:43:31]: uid: (501/osh) gid: (20/20) cmd: test.cgi
[2005-09-19 09:43:31]: cannot stat program: (test.cgi)
However doing a stat on it does work for me.

I've tried changing the ownership of the link and the "SymLinkIfOwnerMatch" but
that doesn't do anything either.

Any insight in this will be greatly appreciated as I've been struggeling with
this for quite some time now.

Is it so that SuExec simply won't follow symlinks and if so, why doesn't the
logfiles state that instead of the "cannot stat" message?

Thanks in advance

Oscar

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message