httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Boysenberry Payne <boysenbe...@humaniteque.com>
Subject [users@httpd] Having error on Apachectl start
Date Thu, 15 Sep 2005 02:44:59 GMT
Hello,

	When I try to start Apache I get the following errors:

dyld: /usr/local/httpd/bin/httpd version mismatch for library: 
/usr/local/httpd/lib/libexpat.0.dylib (compatibility version of user: 
6.0.0 greater than library's version: 2.0.0)
/usr/local/httpd/bin/apachectl: line 100:  2222 Trace/BPT trap          
$HTTPD $ARGV

I installed Apache2 from source using:
./configure --prefix=/usr/local/httpd --with-perl=/usr/bin/perl 
--with-mpm=prefork --enable-mods-shared=all
I also have mod_perl2 installed as a shared mod.
The error only came up after I tried to install APR::Request
It gave an error stating I needed expat so I installed expat-1.95.8.
It allowed me to install APR::Request, but then Apache wouldn't start.
I even tried reinstalling Apache to no avail.
I'm running this on OS X 10.3.9

Any idea how to fix this?  Would this be a darwin list issue?

Any help is appreciated.

Thanks,
Boysenberry

boysenberrys.com | habitatlife.com | selfgnosis.com

Mime
View raw message