httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Atkins <m...@degeneration.co.uk>
Subject [users@httpd] Question marks in URLs on Win32
Date Mon, 22 Aug 2005 09:22:04 GMT
Hi folks,

I'm working on a CMS which uses mod_rewrite to dispatch all URLs through 
a single script. The original URL isn't included in the destination URL 
since the CMS uses REQUEST_URI to get the original URL and decodes it 
manually.

While testing the CMS on a Win32 Apache install I noticed that the 
Windows version of Apache seems to reject outright any URL containing an 
escaped question mark (%3F). The server replies with a 403 Forbidden 
message.

Testing reveals that this isn't specific to our rewrite setup: any Win32 
Apache will do this for any URL containing an escaped question mark. 
Apache under Linux doesn't seem to exhibit this.

I assume this has something to do with a question mark not being allowed 
in filenames under Windows, but the CMS isn't mapping the path onto the 
filesystem at all so this restriction is unnecessary in this case. Is 
there some way to disable this check?


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message