httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jsl...@gmail.com>
Subject Re: [users@httpd] Rewrites in .htaccess work with http but not https?
Date Mon, 11 Jul 2005 00:11:59 GMT
On 7/8/05, Markus Mayer <mymaillists@gmx.at> wrote:
> Hallo Everybody! :-)
> 
> I have a really strange problem for which I can't find a solution.
> 
> I have a .htaccess file with a simple rewrite rule in it which right now just
> rewrites from one non existent file to an existing file (see below).  These
> rules work fine when I call up the pages through a http call, but when I do
> it using https, I get an "Internal Server Error".  The error log for the
> https contains entries with "RewriteEngine not allowed here".  If I remove
> the RewriteEngine On line, then I get "RewriteRule not allowed here".  In the
> apache server config, I have an entry for the directory with "AllowOverride
> All" in both http and https.  I'm rellay at a loss as to what's happening.
> Does anyone have any ideas?

Check for every instance of the AllowOverride directive in all your
apache config files and make sure that you don't have one overriding
your "all".

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message