httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bert_De_Rid...@peopleware.be
Subject [users@httpd] SetHandler not working ?
Date Mon, 04 Jul 2005 10:38:27 GMT
Hi, all, 

I'm running Apache 2 on SuSE Linux 9.0 and I'm trying to make mod_mono 
work. 
I have already had succes with it on SuSE 9.3 without virtual host. 

However, somehow on the 9.0 the handler seems to be bypassed. 
When I request a page index.aspx, I get the content of the file, not the 
result of the processed code. 

Here are the (I think) relevant pieces of the configuration. 

I am also running a zope web server on port 8080, maybe that is of 
interest to you. 

Any clues anyone ? 



LoadModule access_module /usr/lib/apache2-prefork/mod_access.so 
LoadModule actions_module /usr/lib/apache2-prefork/mod_actions.so 
LoadModule alias_module /usr/lib/apache2-prefork/mod_alias.so 
LoadModule auth_module /usr/lib/apache2-prefork/mod_auth.so 
LoadModule auth_dbm_module /usr/lib/apache2-prefork/mod_auth_dbm.so 
LoadModule autoindex_module /usr/lib/apache2-prefork/mod_autoindex.so 
LoadModule cgi_module /usr/lib/apache2-prefork/mod_cgi.so 
LoadModule dir_module /usr/lib/apache2-prefork/mod_dir.so 
LoadModule env_module /usr/lib/apache2-prefork/mod_env.so 
LoadModule expires_module /usr/lib/apache2-prefork/mod_expires.so 
LoadModule include_module /usr/lib/apache2-prefork/mod_include.so 
LoadModule ldap_module /usr/lib/apache2-prefork/mod_ldap.so 
LoadModule auth_ldap_module /usr/lib/apache2-prefork/mod_auth_ldap.so 
LoadModule log_config_module /usr/lib/apache2-prefork/mod_log_config.so 
LoadModule mime_module /usr/lib/apache2-prefork/mod_mime.so 
LoadModule negotiation_module /usr/lib/apache2-prefork/mod_negotiation.so 
LoadModule rewrite_module /usr/lib/apache2-prefork/mod_rewrite.so 
LoadModule setenvif_module /usr/lib/apache2-prefork/mod_setenvif.so 
LoadModule ssl_module /usr/lib/apache2-prefork/mod_ssl.so 
LoadModule suexec_module /usr/lib/apache2-prefork/mod_suexec.so 
LoadModule userdir_module /usr/lib/apache2-prefork/mod_userdir.so 
LoadModule php4_module /usr/lib/apache2-prefork/libphp4.so 
LoadModule mono_module /usr/lib/apache2/mod_mono.so 

NameVirtualHost * 

<virtualhost *> 
  ServerName asp.my.domain 

  Alias /aspnet "/usr/share/doc/xsp/test" 
  MonoApplications "/aspnet:/usr/share/doc/xsp/test" 
  <Directory /usr/share/doc/xsp/test> 
    SetHandler mono 
    DirectoryIndex index.aspx 

    Order allow,deny 
    Allow from all 

  </Directory> 

  ErrorLog /var/log/apache2/error-asp.log 
  LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" 

  TransferLog /var/log/apache2/transfer-asp.log 
</virtualhost> 


Any help greatly appreciated 





Kind regards,

Bert De Ridder

PeopleWare NV - Head Office
Cdt.Weynsstraat 85 
B-2660 Hoboken 
Tel: +32 3 448.33.38 
Fax: +32 3 448.32.66 

PeopleWare NV - Branch Office Geel
Kleinhoefstraat 5
B-2440 Geel
Tel: +32 14 57.00.90
Fax: +32 14 58.13.25

u r lame if u insist on trying 2 b l337 by abbrev evythng u type when 
asking ppl 4 hlp. kiddie speak is teh sux. ppl. plz stop teh kiddie speak. 
thx.
hint: aol kiddie speak is not cool, it just makes people not want to read 
your post.


Mime
View raw message