httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Kelsch <r...@csst.net>
Subject [users@httpd] Weird CGI problem in Windows XP
Date Sat, 23 Jul 2005 17:20:49 GMT
Hello,

I am having a bizarre problem with Apache running on my Windows
development machine.  I've been using Apache on this machine for many
months replicating an unusual production environment and until recently
it has been rock solid.

None of my Perl scripts run anymore via Apache.

Let me explain.  I've been writing simple Perl CGI scripts to run on a
local Apache service via port 8888.  Using a web browser on localhost
has been an easy way of writing friendly software with a familiar web
interface.  All of the production machines do not have the problem, but
suddenly and out of the blue my CGI scripts refused to run.  When I
click on the link to run them I get no response.  At the bottom of the
browser status bar I get a quick "loading" message and then a "Done" and
nothing has changed, as if I never clicked on the link.

Before, it would run the script and show its output.  I have many
scripts and it fails on all of them now.  It's driving me crazy.

I checked the error logs and nothing shows up just the starting up of
Apache messages.  I typed in a bogus path and that showed up in the
error logs.

So I got frustrated, uninstalled Apache and Activestate's Perl.  Cleaned
out the registry, cleaned out the directory remnants and the directories
themselves.  Restarted the machine, reinstalled Apache and Perl,
restarted the machine again.  Loaded up my Firefox browser and tried it
again.  The same doggone thing happened.  I've gone through the
configuration line by line.  Nothing is out of the ordinary.

What's going on?  I never had this trouble in my life with Apache on a
Windows machine.

I've done the usual scan for viruses, adware, etc.  The system is
clean.  It ran the scripts manually from the command line and they work
just fine.  Perl works just fine.  Yet, for some reason Perl and Apache
refuse to work together.

A few answers to possible questions:

*  Yes, the Perl binary is in the PATH variable.
*  Yes, I have a #!Perl line, even though I never needed one.
*  Yes, the Perl scripts run from a command line without troubles.   A
simple "perl [scriptname]" works fine.
*  No, nothing shows in the access nor error logs.
*  No, nothing happens when I type in manually the path to the CGI
script.  I hit enter and nothing happens.  The browser acts like it's
done after a brief second of apparent handshaking.
*  Yes, I have completely started from scratch with fresh installs of
both Perl and Apache (I even removed all traces of them before
installing anew) and recreated the configure file for Apache.  Still no
difference.
*  Yes, Apache feeds web pages, but no longer runs CGI scripts.  I have
left the default CGI settings in the configure file, in case you wanted
to know that.
*  Yes, production machines work just fine.  Something happened with my
development machine and I beg anyone for help.

I'm at a loss, and I really need to get it working again.  This mimics
my production environment so changes are not possible.  All are Windows
XP Professional machines with Apache 2.0.53 (or 54), Perl 5.8.7-813 from
ActiveState, and Firefox web browsers.  The production machines are NOT
connected to any network.   The Apache server is just a simple means to
gain an easy web browser based GUI for the Perl scripts.

Thank you ahead of time for any suggestions you can offer me.  I'm stumped.

Richard Kelsch



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message