httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Cook <scli...@gmail.com>
Subject Re: [users@httpd] Starting Apache2 on Win2k as another user
Date Sun, 17 Jul 2005 07:16:02 GMT
I fixed my problem as stated in the last email, but now I've narrowed it 
down, and thought I'd post it for the archives.

The user that apache2 runs as needs the following permissions on Windows 
2000 (keep in mind they are inheritable to the subdirectories):

* "List Folder Contents" on the root directory of the drive itself (in 
my case "E:\"

* "Read and Execute" and "Read" on the bin\ directory in the apache root 
("E:\Apache Group\Apache2\bin\")

* "Read" on the conf\ directory in apache root ("E:\Apache 
Group\Apache2\conf\")

* "Read" and "Write" to the logs\ directory in the apache root 
("E:\Apache Group\Apache2\logs\")

* "Read" and "Rean and Execute" on the modules\ directory in the apache 
root ("E:\Apache Group\Apache2\modules\")

I'm willing to bet it'd need "Read" and "Read and Execute" for the 
cgi-bin\ directory if you use that, and "Read" on the manual\, errors\, 
icons\, and htdocs\ directories if you use those.

Of course, if I am blatantly wrong about any of this please correct the 
information, I'm trying to help anyone else who needs it but obviously I 
am no guru.




DaedalWorks wrote:
> Stephen Cook wrote:
> 
>> I am trying to get Apache2 (v2.0.54) to run as a service on Windows 
>> 2000 as a specific user ("apacheuser", original name huh?), which only 
>> has rights to read and execute on Apache2 root directory, and full 
>> access to the logs directory.
>>
>> When I start the service as local user (when I am logged in as admin) 
>> it works fine, but when I change the service to log on as "apacheuser" 
>> it doesn't start. There is a message in the Event Viewer that says 
>> "The Apache2 service terminated with service-specific error 1." and 
>> another message that says "The Apache service named  reported the 
>> following error: Apache.exe: could not open document config file 
>> bin/conf/httpd.conf     . "
> 
> 
> I'm not even getting that far with 2.0.54 on Windows XPsp2.  I can run 
> apache from a console window with no problem, but when I try to start it 
> as a service, either from the console or from ApacheMonitor or the 
> Services menu, I get the "service-specific error 1" but no other messages!
> 
> --DLM
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 
> 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message