httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From s...@conman.org (Sean Conner)
Subject Re: [users@httpd] error apache+mod_ssl
Date Thu, 14 Jul 2005 03:46:47 GMT
It was thus said that the Great tiara forever once stated:
> 
> Dear all,
> 
> i have a trouble with apache (1.3.33) with mod_ssl (2.8.22) in RedHat 9.0
> step 1..install openSSL it's OK,
> step 2 install apache+mod_ssl Error :

  [ snip ]

> please advice

  A shellscript I wrote to configure Apache 1.3 with mod_php, mod_perl,
mod_ssl and mod_dav:

#!/bin/bash

cd /root/apps/apache_1.3.31

        ./configure --with-layout=Apache

cd /root/apps/php-4.3.8

        ./configure --with-apache=/root/apps/apache_1.3.31/     \
                --prefix=/usr/local/apache/php                  \
                --with-zlib                                     \
                --with-mysql

        make
        make install

cd /root/apps/mod_ssl-2.8.19-1.3.29

        ./configure --with-apache=/root/apps/apache_1.3.31/

cd /root/apps/mod_perl-1.29

        perl Makefile.PL                        \
               APACHE_SRC=../apache_1.3.31/src  \
               DO_HTTPD=1                       \
               USE_APACI=1                      \
               PREP_HTTPD=1                     \
               EVERYTHING=1

        make
        make install

cd /root/apps/mod_dav-1.0.3-1.3.6

        ./configure --with-apache=/root/apps/apache_1.3.31
        make
        make install 

cd /root/apps/apache_1.3.31

        SSL_BASE=SYSTEM ./configure --with-layout=Apache        \
                --enable-module=rewrite                         \
                --enable-module=info                            \
                --enable-module=ssl                             \
                --enable-module=info                            \
                --enable-module=proxy                           \
                --activate-module=src/modules/perl/libperl.a    \
                --activate-module=src/modules/php4/libphp4.a    \
                --activate-module=src/modules/dav/libdav.a

# end of script

Note that I configure Apache *twice*---once at the beginning, then once
after everything else has been configured, made and installed.

  -spc (Hope this helps some ... )


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message