httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael D. Berger" <m.d.ber...@ieee.org>
Subject [users@httpd] Problem with Redirect
Date Thu, 28 Jul 2005 02:19:25 GMT
I have not been able to get Redirect to work.  Particulars
are below.  Advice would be much appreciated.

Thanks,
Mike.

--
Michael D. Berger
m.d.berger@ieee.org 
--

DNS has cnames www.mysite.net and test.mysite.net

Linksys routes port 80 to 192.168.1.10

On 192.168.1.10, running RH-E-WS-3:
   (I will soon install WS-4, but it is 235 days since the
    last reboot, and I loathe to stop it.)

rpm -q httpd httpd-2.0.46-25.ent

In /etc/hosts:

192.168.1.11   test.mysite.net

In httpd.conf:

<VirtlHost 192.168.1.10>
   ServerName www.mysite.net
   DocumentRoot "/var/www/html/www"
</VirtualHost>

<VirtlHost 192.168.1.10>
   ServerName test.mysite.net
#   DocumentRoot "/var/www/html/www"      # I tried with and without this
   Redirect /index.html http://test.mysite.net/index.html
</VirtualHost>

# I tried numerous versions of Redirect and RedirectMatch.

#From a remote site, http://test.mysite.net finds nothing, although
#192.168.1.10 shows 302 in its log.

#From 192.168.1.10, telnet test.mysite.net 80 followed
#by GET succeeds as expected.



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message