httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Granvin" <Robert.Gran...@metrostate.edu>
Subject [users@httpd] "cannot assign requested address" error on boot, but not on manual start...?
Date Thu, 02 Jun 2005 15:43:15 GMT
I'm hoping for some insight and suggestions on this one...

Our apache /etc/init.d (very straightforward, by the way) works when you execute it by hand,
but does not function correctly during a system boot.

During boot, we receive the following errors (only the IP address has been changed in the
example)

   apache: starting
   (99)Cannot assign requested address: make_sock: could not bind to address 12.34.56.78:80
   no listening sockets available, shutting down
   Unable to open logs
   Done!


ALL other services (Coldfusion, tomcat, etc.) start up successfully during boot, which all
reside in the same disk tree as well.

When the startup script is run immediately after boot, it works great:

   apache: starting
   Done!


Does anyone have any ideas or suggestions for us?  Having to manually restart after a reboot
is really kindof a pain.  :-)


\\ Robert J. Granvin                                             Webmaster
 \\ robert.granvin@metrostate.edu                       Metro State University


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message