httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jsl...@gmail.com>
Subject Re: [users@httpd] Apache2 hangs w/o responding on FBSD 5.4
Date Mon, 27 Jun 2005 20:32:03 GMT
On 6/27/05, Artem Kuchin <matrix@itlegion.ru> wrote:
> Hi!
> 
> I have a very bad problem. We are running about 20 jails
> on freebsd. Each has one apache (2.0.54) and one jails
> has about 80 httpds each running from its own user (non
> root startup). Php5 module is compiled in. Everything else
> is the same as after installtion from the FreeBSD ports
> (source built).
> Appoximately once in a day one or two of those 80 sites
> just stops responding. The httpds are still there, but it does
> not send any data back. If i do kill -1 httpd_pid it usually help,
> but sometimes it does not.
> The sites do not get much traffice. Maybe about 50 hits per
> hours. Nothing fancy. Just plain html+ssi. Sometimes very
> simple PHP. Some have a lot of php and mysql connection.
> We had this problem on FreeBSD 5.2,5.3 and now we have
> on 5.4 with the latest Apache. Our clients are pissed off ;(
> Maybe someone has any idea what's going on and how to
> solve the problem?

Make sure you're compiled with debug symbols, then attach to a frozen
thread with a debugger and see what it is up to.  Stuck in a database
connection would be a good bet.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message