httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Slive <jsl...@gmail.com>
Subject Re: [users@httpd] php scripts run except in cgi-bin
Date Thu, 09 Jun 2005 20:28:47 GMT
On 6/9/05, Ivan Barrera A. <Bruce@ivn.cl> wrote:
> Jean-Christophe Montigny wrote:
> > (be aware, that is an obvious question)
> >
> > Do you have the line
> > #/usr/bin/php
> 
> #!/path/to/exe
> 
> 
> 
> > (or whatever your path to php is) at its beginning?
> >
> > As well, you cannot send raw data just like a normal php script.
> > Just like any CGI you need to send the string
> > Content-type: text/html
> >
> > there's another line but I cannot remember... just google about
> > structure for perl cgi script, it's the same lines.
> >
> > gradeAstudent.com.au wrote:
> >
> >> Anyone have any pointers on getting php scripts to run from the cgi-bin
> >> directory? I can run php scripts fine so long as they are not in the
> >> default
> >> cgi-bin folder.

Hmmm... I'm guessing this person wants to run the php module, not php
as a CGI.  Hence the problem is that apache assumes everything in a
ScriptAlias'ed directory is a CGI.  To fix this, replace the
ScriptAlias /cgi-bin/ /whatever/
with
Alias /cgi-bin/ /whatever/

But be careful, since this will also disable any real CGI scripts.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message