httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From N Lamb <ndl...@engleonline.com>
Subject [users@httpd] Quick Directory Question...
Date Wed, 01 Jun 2005 20:22:33 GMT
My Setup:

Apache 1.3 on mac xserve with virtual hosting setup...

I have a problem with my server when I turn off "Performance Cache" in 
the GUI My site returns a "You do not have permission to access...." 
error when trying to get to my site (just the main page which is a 
redirect to deeper in the site structure,  if you type in the entire 
full path name to the true home page it is still there just the 
redirect which is in the main root folder stops working)... I am 
wondering if this little directory code is causing the problem??

Here is my logic... right now with "performance cache" turned on the 
box sees everyone as coming from itself which is 111.111.111.19 so it 
allows everyone to access what they need to access... when I turn 
performance cache off the box see everyone coming from their own "true" 
IP addresses and Denys them access.

Here is the code:

<Directory "/Library/WebServer/Documents">
Order Deny,Allow
Deny from All
Allow from 111.111.111.19
</Directory>


Is my logic correct? Or am I completely not understanding this Apache 
stuff??

Thanks,

Nathan Lamb


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message