httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "gradeAstudent.com.au" <technolog...@gradeastudent.net.au>
Subject [users@httpd] php scripts run except in cgi-bin
Date Mon, 09 May 2005 12:45:11 GMT
Anyone have any pointers on getting php scripts to run from the cgi-bin
directory? I can run php scripts fine so long as they are not in the default
cgi-bin folder. Alas, however, a survey program I am trying to test (not
written by me) needs to have its scripts in the cgi-bin folder for some
reason.

I have tried the permissions (even set to 777!) and changed the uid gid to
www:www. Perl scripts run fine from this cgi-bin folder which is really
bugging me.

I have set ExecCGI in the Options on the cgi-bin folder as well as allow all
and all that jass in the <Directory> statements.

It just seems like apache has some security feature that prevents php from
running in this one folder (even when i move it and reconfigure httpd.conf
to point to a different folder under the data dir).

Squirellmail which makes extensive use of php is running fine, so I'm fairly
'confident' that php is setup ok?



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message