httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Jostock <markus.jost...@softwareag.com>
Subject [users@httpd] Configuring Apache2.0.54 --with-berkeley-db fails
Date Mon, 06 Jun 2005 09:10:27 GMT
Hi

Ooops - I posted this on user-info@... - my apologies!

I am desparate...

My intention is to access SubVersion via Apache's WebDAV feature.
I am trying to compile Apache 2.0.54 with support for BerkeleyDB 4.3. 
under Linux.

Compilation and installation of Berkeley DB worked fine and I installed 
it under /usr/local/BerkeleyDB.4.3 (./configure;make;make install as root).

But when I try to configure Apache with the option --with-berkeley-db, 
it always ends with an error message although configure seems to find 
BerkeleyDB, as the log reports.

Could someone please give me a little help here? I would really 
appreciate your advice.

I am executing the following command(s) in a script (called runconf.httpd):
==============================
CC=gcc
CFLAGS="-Wall -O3"
LDFLAGS="-L/usr/local/BerkeleyDB.4.3/lib -R/usr/local/BerkeleyDB.4.3/lib"

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/BerkeleyDB.4.3/lib

./configure \
   --prefix=/usr/local/apache2.0.54 \
   --enable-auth-digest \
   --enable-deflate \
   --enable-so \
   --enable-dav \
   --enable-dav-fs \
   --enable-ssl \
   --with-dbm=db43 \
   --with-berkeley-db=/usr/local/BerkeleyDB.4.3

This gives me the following error log (shortened):
===================================
checking for chosen layout... Apache
checking for working mkdir -p... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
Configuring Apache Portable Runtime library ...
checking for APR... reconfig
configuring package in srclib/apr now
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
Configuring APR library
Platform: i686-pc-linux-gnu
checking for working mkdir -p... yes
APR Version: 0.9.6
checking for chosen layout... apr
checking for gcc... gcc
[...]
checking for Berkeley DB 4.3 in /usr/local/BerkeleyDB.4.3...
checking db43/db.h usability... yes
checking db43/db.h presence... yes
checking for db43/db.h... yes
checking for -ldb-4.3... yes
 setting APRUTIL_INCLUDES to "-I/usr/local/BerkeleyDB.4.3/include"
 setting APRUTIL_LDFLAGS to "-L/usr/local/BerkeleyDB.4.3/lib"
checking for Berkeley DB... found db4
checking for default DBM... sdbm (default)
 setting APRUTIL_EXPORT_LIBS to "-ldb-4.3"
 setting APRUTIL_LIBS to "-ldb-4.3"
checking for Expat in /usr... yes
 adding "-lexpat" to APRUTIL_EXPORT_LIBS
 adding "/usr/lib/libexpat.la" to APRUTIL_LIBS
checking iconv.h usability... yes
checking iconv.h presence... yes
checking for iconv.h... yes
checking for type of inbuf parameter to iconv... char **
checking for iconv.h... (cached) yes
checking langinfo.h usability... yes
checking langinfo.h presence... yes
checking for langinfo.h... yes
checking for nl_langinfo... yes
checking for CODESET in langinfo.h... yes
checking for library containing crypt... -lcrypt
checking if system crypt() function is threadsafe... no
checking for crypt_r... yes
checking style of crypt_r... struct_crypt_data
 adding "/home/markus/tmp/httpd-2.0.54/srclib/apr/libapr-0.la" to 
APRUTIL_LIBS
 adding "-lrt" to APRUTIL_LIBS
 adding "-lm" to APRUTIL_LIBS
 adding "-lcrypt" to APRUTIL_LIBS
 adding "-lnsl" to APRUTIL_LIBS
 adding "-lpthread" to APRUTIL_LIBS
 adding "-ldl" to APRUTIL_LIBS
configure: creating ./config.status
config.status: creating export_vars.sh
config.status: creating apu-config
config.status: creating build/pkg/pkginfo
config.status: creating include/private/apu_select_dbm.h
config.status: creating include/apr_ldap.h
config.status: creating include/apu.h
config.status: creating include/apu_want.h
config.status: creating Makefile
[...]
Construct makefiles and header files...
creating config_vars.mk
configure: creating ./config.status
creating modules/aaa/Makefile
creating modules/arch/win32/Makefile
creating modules/cache/Makefile
creating modules/echo/Makefile
creating modules/experimental/Makefile
creating modules/filters/Makefile
creating modules/loggers/Makefile
creating modules/metadata/Makefile
creating modules/proxy/Makefile
creating modules/ssl/Makefile
creating modules/test/Makefile
creating os/unix/Makefile
creating server/mpm/Makefile
creating server/mpm/prefork/Makefile
creating modules/http/Makefile
creating modules/dav/main/Makefile
creating modules/generators/Makefile
creating modules/dav/fs/Makefile
creating modules/mappers/Makefile
creating Makefile
creating modules/Makefile
creating srclib/Makefile
creating os/beos/Makefile
creating os/os2/Makefile
creating os/Makefile
creating os/unix/Makefile
creating server/Makefile
creating support/Makefile
creating srclib/pcre/Makefile
creating test/Makefile
config.status: creating docs/conf/httpd-std.conf
config.status: creating docs/conf/ssl-std.conf
config.status: creating include/ap_config_layout.h
config.status: creating support/apxs
config.status: creating support/apachectl
config.status: creating support/dbmmanage
config.status: creating support/envvars-std
config.status: creating support/log_server_status
config.status: creating support/logresolve.pl
config.status: creating support/phf_abuse_log.cgi
config.status: creating support/split-logfile
config.status: creating build/rules.mk
config.status: creating build/pkg/pkginfo
config.status: creating include/ap_config_auto.h
config.status: include/ap_config_auto.h is unchanged
config.status: executing default commands
./runconf.httpd: line 29: --with-dbm=db43: command not found

Using --with-dbm=db4 shows the same error.

Not using the instruction  --with-dbm=db43 leads to an error in the next 
line for --with-berkeley-db

Using --with-berkeley-db=/usr/local/BerkeleyDB.4.3 leads to
[...]
./runconf.httpd: line 30: --with-berkeley-db=/usr/local/BerkeleyDB.4.3: 
No such file or directory

Using --with-berkeley-db without parameters leads to
[...]
./runconf.httpd: line 30: --with-berkeley-db: command not found

Why doesn't it find Berkeley DB? What am I doing wrong here? I would be 
really grateful for your hints.

Thanks

   Markus

Markus Jostock <http://www.softwareag.com>



Software Engineer

Software AG Belgium S.A. Succursale de Luxembourg

R&D



	

	
<markus.jostock@softwareag.com <mailto:markus.jostock@softwareag.com>>

HTML Mail



Rue Glesener 56

Luxembourg

1630

Luxembourg



	

	
Work:

+352 29 21 22

Fax:

+352 29 21 20



Software AG - The XML company



Additional Information:





	
Last Name



	
Jostock





	
First Name



	
Markus





	
Version



	
2.1









	






Mime
View raw message