httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Iori Honda <patriot_b...@nifty.com>
Subject [users@httpd] apache 1.3.33 Timeout on CGI
Date Thu, 16 Jun 2005 06:05:59 GMT
I build apache 1.3.33 on Solaris and run test cgi which
fources timeout on httpd. It seems Internet explorer
trys re-connection to httpd server when timeout from apache 
happens. The same URL is called 2-3 times. This is strange.
But this is a browser issue.

I checked apache behavior when timeout happens. I used this 
simple cgi to see what happens when timeout happens.
This program is dedicated to simulate a long run cgi application.

---
#!/usr/bin/perl

for ($i=0;$i<60*7;$i++){
sleep(1);
}
print "Content-Type: text/html\n\n";
print "test cgi end\n"; 
--

I used etherreal to check packet between httpd and browser.
After 300 seconds passed (default Timeout time), httpd
sent just FIN packet to browser, then browser return ACK and FIN
and httpd sent ACK. tcp connection was closed successfully, abruptly.

Looking at timeout() function in httpd, httpd just close socket
by using close().

Is this expected behavior ? Why httpd does not send 
any error code/message to client ? From browser, httpd disconnects 
abruptly. This is not friendly.

---
Iori Honda
patriot_blue@nifty.com

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message