httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Carel <kirby_12172...@yahoo.com>
Subject RE: [users@httpd] WAP .htaccess authentication
Date Wed, 22 Jun 2005 08:35:47 GMT



--- Boyle Owen <Owen.Boyle@swx.com> wrote:

> 
> 
> > -----Original Message-----
> > From: Michael Carel
> [mailto:kirby_12172004@yahoo.com]
> > Sent: Mittwoch, 22. Juni 2005 09:30
> > To: users@httpd.apache.org
> > Subject: RE: [users@httpd] WAP .htaccess
> authentication
> > 
> > 
> > What I mean is, the WAP browser doesnt prompt for
> any
> > authentication, it goes directly to the index
> pages.
> > But using html browser htaccess prompts for
> > authentication.
> 
> OK.. That's clear (It could have been that you were
> denied access..)
> 
> > 
> > error_log doesnt show any error, but access_log
> show
> > the ff:
> > 10.152.192.200 - administrator
> [22/Jun/2005:15:07:17
> > +0800] "GET /wap/test/ HTTP/1.1" 200 1156
> > 10.152.192.200 - administrator
> [22/Jun/2005:15:08:26
> > +0800] "GET /wap/test/ HTTP/1.1" 200 1156
> > 
> > and my wap gateway also shows:
> > 2005-06-22 14:23:14 [30380] [6] INFO: Fetching
> > <http://172.16.59.164/wap/test/>
> > 2005-06-22 15:07:17 [30380] [6] INFO: Fetching
> > <http://172.16.59.164/wap/test/>
> > 2005-06-22 15:08:26 [30380] [6] INFO: Fetching
> > <http://172.16.59.164/wap/test/>
> 
> Is your server active at the moment? It would help
> if it were (I tried the URL but got a timeout).
> 
> > 
> > any idea why or do i missed something with my
> config
> > below?
> 
> Do you understand how basic authentication works?
> The first time you request the page, you don't have
> any credentials (user/pass) so the server responds
> 404. This causes the client to pop-up the password
> challenge and cache the credentials. It then sends
> them in a header with every subsequent request in
> that realm. 
> 
> It's a bit strange that you get allowed access. That
> means something must be passing the credentials -
> could the gateway have cached them?

Thanks, for the Tip, its actually works now, its my
Ericsson Mobile Phone who is caching all the password
that is previously used. htaccess once works during my
first setup of this wap site. Ericsson Mobile Phone 
has a different caching option for passwords which is
not common on other mobile phones. I used to "Clear
Cache" in my Ericsson Phone and overlooked the "Clear
Password List Cache" Option. It is the Mobile Phone
who's making all the problem.

Thanks for the Help...



> 
> Are you sure that the browser and the WAP device are
> accessing *exactly* the same URL? Can you post it
> and I'll try it...
> 
> Rgds,
> Owen Boyle
> Disclaimer: Any disclaimer attached to this message
> may be ignored. 
> 
> > 
> > thanks for the reply..
> > 
> > 
> > 
> > 
> > --- Boyle Owen <Owen.Boyle@swx.com> wrote:
> > 
> > > Plain text please...
> > Sorry..
> > > 
> > > What does "does not work" mean?
> > > 
> > > Describe *exactly* what happens in the browser
> > > (cut'n'paste messages) and what you get in the
> > > apache error_log.
> > > 
> > > Rgds,
> > > Owen Boyle
> > > Disclaimer: Any disclaimer attached to this
> message
> > > may be ignored. 
> > > 
> > > -----Original Message-----
> > > From: Michael Carel
> > > [mailto:kirby_12172004@yahoo.com]
> > > Sent: Mittwoch, 22. Juni 2005 09:01
> > > To: users@httpd.apache.org
> > > Subject: [users@httpd] WAP .htaccess
> authentication
> > > 
> > > 
> > > Hi to all;
> > > 
> > > I am trying to password protect a directory that
> > > contains a .wml page. I am running Apache 1.3.29
> in
> > > a Linux Advance server and do use ".htaccess"
> > > ....but it does not work for .wml . htaccess
> > > authentication work with html browser but not in
> a
> > > WAP mobile browser.
> > > 
> > > I configure http.conf to include wap parameters:
> > > 
> > > DirectoryIndex  index.wml
> > >  Addtype text/vnd.wap.wml wml
> > >  Addtype application/vnd.wap.wmlc wmlc
> > >  Addtype text/vnd.wap.wmlscript wmls
> > >  Addtype application/vnd.wap.wmlscriptc wmlsc
> > >  Addtype image/vnd.wap.wbmp wbmp 
> > > 
> > > And the .htaccess:
> > > 
> > > AuthName "WAP Access"
> > > AuthType Basic
> > > AuthUserFile /home/www/htdocs/wap/htpasswd.users
> > > require valid-user
> > > 
> > > 
> > > This works if browsed with an http browser but
> not
> > > in WAP mobile browser. Do I missed something?
> I've
> > > searched all over the internet but the solution
> > > still doesnt works.
> > > 
> > > Please help me.... and thanks in advanced.
> > > 
> > > 
> > > 
> > > Regards,
> > > 
> > > KBC
> > > 
> > >  
> > > 
> > > Send instant messages to your online friends
> > > http://uk.messenger.yahoo.com 
> > > Diese E-mail ist eine private und persönliche
> > > Kommunikation. Sie hat keinen Bezug zur Börsen-
> bzw.
> > > Geschäftstätigkeit der SWX Gruppe. This e-mail
> is of
> > > a private and personal nature. It is not related
> to
> > > the exchange or business activities of the SWX
> > > Group. Le présent e-mail est un message privé et
> > > personnel, sans rapport avec l'activité
> boursière du
> > > Groupe SWX.
> > >  
> > >  
> > > This message is for the named person's use only.
> It
> > > may contain confidential, proprietary or legally
> > > privileged information. No confidentiality or
> > > privilege is waived or lost by any
> mistransmission.
> > > If you receive this message in error, please
> notify
> > > the sender urgently and then immediately delete
> the
> > > message and any copies of it from your system.
> > > Please also immediately destroy any hardcopies
> of
> > > the message. You must not, directly or
> indirectly,
> > > use, disclose, distribute, print, or copy any
> part
> > > of this message if you are not the intended
> > > recipient. The sender's company reserves the
> right
> > > to monitor all e-mail communications through
> their
> > > networks. Any views expressed in this message
> are
> > > those of the individual sender, except where the
> > > message states otherwise and the sender is
> > > authorised to state them to be the views of the
> > > sender's company.
> > > 
> > >
> >
>
---------------------------------------------------------------------
> > > The official User-To-User support forum of the
> > > Apache HTTP Server Project.
> > > See <URL:http://httpd.apache.org/userslist.html>
> for
> > > more info.
> > > To unsubscribe, e-mail:
> > > users-unsubscribe@httpd.apache.org
> 
=== message truncated ===


Send instant messages to your online friends http://uk.messenger.yahoo.com 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message