httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randip Kumar MALAKAR <randip.mala...@st.com>
Subject [users@httpd] Httpd 2.0.54- mod_auth_ldap Require ldap-attribute directive Not working
Date Wed, 15 Jun 2005 09:58:16 GMT
Hi all,
	I am using  Apache/2.0.54 on Redhat Linux 9.0.
I am using mod_auth_ldap module for LDAP authentication/authorization. When I use 'require
valid-user' Directive it works well for
any authenticated user. But when I use 'require ldap-attribute' Directive, it does not work.
In the error log it gives:

------------------
[Wed Jun 15 19:53:28 2005] [error] [client 138.198.194.1] access to /manual failed, reason:
unknown require directive:"ldap-atribute
c=IND"
------------------

My config is as below:

-----------------------------------
<Location "/manual">
AuthLDAPURL ldap://ldaphost:389/ou=People,dc=domain,dc=com?uid?one?(objectClass=*)
AuthType basic
authname Secret
#####require valid-user
require ldap-attribute c=IND
</Location>
-----------------------------------


Here I want to allow LDAP user having attribute value 'c=IND'. This attribute is anonymously
accessible via LDAP.

In the mod_auth_ldap document the 'require ldap-attribute' syntax is available but not in
example section.

Please help how to succeed.

Thanks in advance.

Regards
Randip Malakar



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message