httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lindo Nepi <asc...@ascu.unian.it>
Subject [users@httpd] CGI segfault on my linux/sparc-64
Date Mon, 23 May 2005 11:24:27 GMT


hi all
i have a problem if i try, using CGI or  php , to run an application..



actually i run this application ( gradsc: from the scientific 
package GraDS) on my linux/x86 machine..with 
apache 1.3.33 (linux debian)..it works fine!

the problem is that i must migrate this configuration on a debian 3.1
on my sparc64, apache  1.3.33:
i try to launch a simple CGI (write in bash) from apache...
this CGI launch gradsc (a scientific application that generate gif images)
...but in my webpage i obtain an exit code 11

look on my log , in /var/log/apache/error.log i found:
/usr/lib/cgi-bin/myscript.cgi: line 19: 15964 Segmentation fault    gradsc


on my debian/x86
no problem with the same configfuration.. gradsc works fine if i launch 
it from the CGI or php.

of course i compiled gradsc on sparc64...
if i run gradsc from bash (on sparc64 ad on x86) it works correctly.

problem is only if i run gradsc through apache on sparc64 ...any ideas?


how can i find the error?


thanks in advance

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message