httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From PMilan...@nypl.org
Subject RE: [users@httpd] Migrating to new server
Date Wed, 18 May 2005 15:50:08 GMT
Looks to me like it may still be a permissions issue. It can't find the
file because it cannot read the directory, and it can't read the file so
it bounces permission denied. What user is apache(http) run as (ps -ef),
and what are the permissions of the directory? (ls -la /home/web/includes)

 

If it were version problems, you'd likely see it in the php reporting.
Apache proxying the error for php. Have you looked at the error log? Look
for ERROR in the config. There is also a descriptor for the log location. 

 

P

 

 

 

  _____  

From: rlhumphrey@gmail.com [mailto:rlhumphrey@gmail.com] 
Sent: Wednesday, May 18, 2005 11:14 AM
To: users@httpd.apache.org
Subject: [users@httpd] Migrating to new server

 

We have an old PC running RedHat 7.3 with Apache 1.3.29 (i think) and it
serves out some PHP/MySQL content to our internal users. I migrated
everything on this machine over to a new Server running CentOS 4.0 (Apache
2.0.52). 

Here are the details


Old Box                                             New Box

PHP 4.1.2                                           PHP 4.3.9
MySQL 3.23                                        MySQL 4.1.10
Apache 1.3.29                                     Apache 2.0.52

After migrating everything over we are seeing failures when we add an
include directory. I modified the php.ini to add the includes directory,
in this case /home/web/includes.

On the old server all worked well, but on the new server I get an error
stating that it cant find the file (which is there) in the includes
directory. If we put the entire path in the PHP script to the includes
dir, then we get a permission denied error.

The permissions on both servers are the same.  

I guess my question is this. 

Is this an Apache error or a PHP error. 

Everything worked fine on the old box with identical settings, but it isnt
working on the new box.

Any suggestions on where to start looking.

I did verify permissions are good etc, but maybe i missed something.


-- 
Richard Humphrey 


Mime
View raw message