httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ramsey, Robert L" <robert-ram...@uiowa.edu>
Subject [users@httpd] problems accessing mounted directories
Date Wed, 04 May 2005 18:33:03 GMT
Hi,

I am running RedHat EL AS 4.0, Apache 2.0.52, fully patched.  I have a
Windows 2003 server with a share that contains documents for the
website.  I mount the windows share using the following line in fstab:

//192.xxx.xxx.xxx/web_documents /var/www/html/documents cifs
fmask=755,dmask=755,user,auto,credentials=/root/.webpasswd,uid=67,gid=67
0 0

The mount works correctly.  On my system, 67 is the uid and gid for
apache.  I can log into the box as an unprivileged user, cd into the
directory and read the files with no problem.  If I open konq and type
in file:///var/www/html/documents/index.html, konq opens the file with
no problem.  If I try http://localhost/documents/index.html, I get:

Forbidden

You don't have permission to access /documents on this server.

Additionally, a 403 Forbidden error was encountered while trying to use
an ErrorDocument to handle the request.


I read that Apache might have problems accessing mounted drives, but not
links to mounted drives, so I changed the mount point to
/var/www/documents and did an ln -s /var/www/documents
/var/www/html/documents, but I get exactly the same result.

Any ideas?  In theory, this should be possible, but I can't figure out
what I've messed up.

Thanks,

Bob

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message