httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From N Lamb <ndl...@engleonline.com>
Subject [users@httpd] Problem with Performance Cache and Logs
Date Mon, 02 May 2005 15:54:07 GMT
Apache Newbie Question...

We are using apache (1.3) to host multiple sites on our xserve and most 
all use the same IP address which apache then resolves the request and 
routes them to the proper site. Our problem is this (actually I am 
having two problems):

1. Our main site has a redirect that takes the users to a page located 
down the folder structure about 3 levels so that the pages all load 
under our one folder where tomcat is running to properly handle .jsp 
pages... The problem is that when we turn off Performance Cache this no 
longer redirects at all it returns an error page "page cannot be 
displayed" If we leave performance cache on we cannot get IP addresses 
for our visitors to even see how many people are coming to our sites... 
(I read one of the prior post about if one site is turned on they are 
all on in regards to performance cache). So I need to be able to have 
the site redirect properly but still be able to capture IP address in 
the logs for stats reasons... I really don't care which way this is 
fixed (either the redirect working with Performance Cache turned off; 
or Leave performance cache on and find another way to capture IP 
address for in the logs. (I would prefer to have the performance cache 
turned off but am willing to try anything (within reason) to correct 
theses problems)

2. With this same "main" site I cannot get it to write its log file 
anywhere else other than what I believe is the default location in 
private/var/xxx/xxx/xxx/ if I try to tell it to write to another 
location nothing happens and it continues to write to the old 
location...??? Although in the "Server Settings" control panel it shows 
the new location I designated it still writes to the old location... 
all other sites can be changed no problem with the server settings 
interface... just not this main site???

Our "main" site address is: www.engleonline.com for all to check out 
the redirect and such...

Thanks in advance for any help!

Nathan Lamb
ndlamb@engleonline.com


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message