httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dan <i...@hostinthebox.net>
Subject Re: [users@httpd] DirectoryIndex not working properly
Date Thu, 05 May 2005 23:44:52 GMT
Tim Burden wrote:
> Check permissions on the DocumentRoot directory (and its parents).
> 
> ----- Original Message ----- 
> From: "dan" <info@hostinthebox.net>
> To: <users@httpd.apache.org>
> Sent: Thursday, May 05, 2005 7:13 PM
> Subject: [users@httpd] DirectoryIndex not working properly
> 
> 
> 
>>Hello, all -
>>
>>I'm having a bit of trouble gettind DirectoryIndex to work properly.
>>I've been going over my configs for about two hours, and have found
>>nothing.  I need a new set of eyes.
>>
>>I have 'DirectoryIndex index.htm' set up, and over the years that I've
>>used Apache, I've never seen this.  It's as if mod_dir is not "working"
>>properly.  I can hit http://m.y.i.p/ and the access log records a 404,
>>and that's what I'm presented with in the browser.  However, if I hit
>>http://m.y.i.p/index.htm, the page comes up.
>>
>>Here's some output from ./httpd -l:
>>
>>Compiled-in modules:
>>   http_core.c
>>   mod_env.c
>>   mod_log_config.c
>>   mod_negotiation.c
>>   mod_status.c
>>   mod_include.c
>>   mod_autoindex.c
>>   mod_dir.c
>>   mod_cgi.c
>>   mod_asis.c
>>   mod_actions.c
>>   mod_rewrite.c
>>   mod_access.c
>>   mod_auth.c
>>   mod_so.c
>>   mod_setenvif.c
>>suexec: disabled; invalid wrapper /var/www/bin/suexec
>>
>>mod_dir is clearly compiled in, however, doesn't seem to work.  I have
>>attached my httpd.conf for others to gander over, if they would.  It
>>would help a great deal.
>>
>>Thanks
>>-dant
>>
>>
>>
>>
>>
>>
>>ServerType standalone
>>ServerRoot "/var/www"
>>PidFile /var/www/logs/httpd.pid
>>ScoreBoardFile /var/www/logs/httpd.scoreboard
>>Timeout 300
>>KeepAlive On
>>MaxKeepAliveRequests 100
>>KeepAliveTimeout 15
>>MinSpareServers 5
>>MaxSpareServers 10
>>StartServers 5
>>MaxClients 1024
>>MaxRequestsPerChild 0
>>Port 8080
>>User www
>>Group www
>>ServerAdmin rpmbuild@localhost.localdomain
>>DocumentRoot "/var/www/htdocs"
>><Directory />
>>     Options FollowSymLinks
>>     AllowOverride None
>></Directory>
>><Directory "/var/www/htdocs">
>>     Options +Indexes FollowSymLinks MultiViews
>>     AllowOverride None
>>     Order allow,deny
>>     Allow from all
>></Directory>
>>
>>
>>
>><IfModule mod_dir.c>
>>     DirectoryIndex index.htm
>></IfModule>
>>AccessFileName .htaccess
>><Files ~ "^\.ht">
>>     Order allow,deny
>>     Deny from all
>>     Satisfy All
>></Files>
>>UseCanonicalName On
>>DefaultType text/plain
>>HostnameLookups Off
>>ErrorLog /var/www/logs/error_log
>>LogLevel warn
>>LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\""
>>combined
>>LogFormat "%h %l %u %t \"%r\" %>s %b" common
>>LogFormat "%{Referer}i -> %U" referer
>>LogFormat "%{User-agent}i" agent
>>CustomLog /var/www/logs/access_log common
>>ServerSignature On
>>
>>

The permissions on the DocumentRoot directory are fine.  Again, I'm able 
to hit the index.htm page if I specify it in the URI.  This is an issue 
with DirectoryIndex, I'm quite certaon - not with permissions.

Thanks
-dant

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message