httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rahul Kohli" <rahul_ko...@infosys.com>
Subject RE: [users@httpd] Error while installing Apache 1.3.33 on Solaris 10
Date Thu, 12 May 2005 16:46:15 GMT
 

In order to ensure this is not permission issue I have done the same using root user. Also
checked for Ctrl-M characters and the files are perfectly fine.

Now I am not getting the errors when running "configure" command but on execute the "make"
the error still remains the same (shown below)

 

The version of make on my machine is "RELEASE VERSION SunOS 5.10 s10_73 November 2004". Do
I need to use other version of "make" (make version 3.80 available under sunfreeware.com).
Please suggest.

 

# ./configure --prefix=/test/self/apache1333 --enable-module=proxy   --enable-shared=proxy

Configuring for Apache, Version 1.3.33

 + using installation path layout: Apache (config.layout)

Creating Makefile

Creating Configuration.apaci in src

 + enabling mod_so for DSO support

Creating Makefile in src

 + configured for Solaris 2100 platform

 + setting C compiler to gcc

 + setting C pre-processor to gcc -E

 + using "tr [a-z] [A-Z]" to uppercase

 + checking for system header files

 + adding selected modules

 + using system Expat

 + checking sizeof various data types

 + doing sanity check on compiler and options

Creating Makefile in src/support

Creating Makefile in src/regex

Creating Makefile in src/os/unix

Creating Makefile in src/ap

Creating Makefile in src/main

Creating Makefile in src/modules/standard

Creating Makefile in src/modules/proxy

 

# make

===> src

===> src/regex

<=== src/regex

===> src/os/unix

gcc -c  -I../../os/unix -I../../include   -DSOLARIS2=2100 -DUSE_HSREGEX `../../apaci` os.c

In file included from /usr/include/signal.h:26,

                 from /usr/include/sys/siginfo.h:25,

                 from /usr/include/sys/wait.h:24,

                 from ../../include/ap_config.h:1079,

                 from os.c:21:

/usr/include/sys/signal.h:85: error: syntax error before "siginfo_t"

In file included from /usr/include/sys/siginfo.h:25,

                 from /usr/include/sys/wait.h:24,

                 from ../../include/ap_config.h:1079,

                 from os.c:21:

/usr/include/signal.h:111: error: syntax error before "siginfo_t"

/usr/include/signal.h:113: error: syntax error before "siginfo_t"

*** Error code 1

make: Fatal error: Command failed for target `os.o'

Current working directory /test/self/INs/apache_1.3.33/src/os/unix

*** Error code 1

The following command caused the error:

for i in regex os/unix ap main lib modules; do \

        echo "===> src/$i"; \

        case ".Solaris 2100" in \

          .OS390 | .TPF) ( cd $i && make SDP='src/' OPTIM='') || exit 1;; \

                      *) ( cd $i && make  SDP='src/' CC='gcc' AUX_CFLAGS=' -DSOLARIS2=2100
-DUSE_HSREGEX `./apaci`' RANLIB='true' OPTIM='') || exit 1;; \

        esac; \

        echo "<=== src/$i"; \

done

make: Fatal error: Command failed for target `subdirs'

Current working directory /test/self/INs/apache_1.3.33/src

*** Error code 1

The following command caused the error:

case "xsun4u-sun-solaris2.2100" in \

  x*390*) _C89_STEPS="0xffffffff"; export _C89_STEPS;; \

esac; \

cd ./src; make  SDP=src/ all

make: Fatal error: Command failed for target `build-std'

Current working directory /test/self/INs/apache_1.3.33

*** Error code 1

The following command caused the error:

make -f ./Makefile  root= build-std

make: Fatal error: Command failed for target `build'

 

Thanks,

Rahul 

 

-----Original Message-----
From: Craig Dunigan [mailto:cdunigan@doit.wisc.edu] 
Sent: Thursday, May 12, 2005 12:09 PM
To: users@httpd.apache.org; harish.sundaram@patni.com
Subject: RE: [users@httpd] Error while installing Apache 1.3.33 on Solaris 10

 

Dunno, looks like a straightforward file/directory permissions problem to me.  

Make sure you have write privileges to both the source and destination

directories, or run configure and make under sudo.

 

--

Craig

 

On Thu, 12 May 2005, Harish Sundaram wrote:

 

> Check whether Ctrl-M characters got transferred in your code when u

> transferred the files on to the Solaris machine.

> If that is the case, transfer file in ascii mode.....and try.

> 

> Thanks and Regards,

> Harish.

> x 5337.

> 

> -----Original Message-----

> From: Rahul Kohli [mailto:rahul_kohli@infosys.com]

> Sent: Thursday, May 12, 2005 9:08 PM

> To: users@httpd.apache.org

> Subject: [users@httpd] Error while installing Apache 1.3.33 on Solaris 10

> 

> 

> Hi All,

> 

> I am trying to install Apache 1.3.33 on Solaris 10 machine but am facing

> certain issues while doing so.

> The gcc version on my machine is "gcc version 3.4.3

> (csl-sol210-3_4-branch+sol_rpath)". The steps and the error faced are

> mentioned below.

> 

> 1)

> configure --prefix=/test/self/apache1333 --enable-module=proxy   --enable-sh

> ared=proxy

> Configuring for Apache, Version 1.3.33

>  + using installation path layout: Apache (config.layout)

> Creating Makefile

> Creating Configuration.apaci in src

>  + enabling mod_so for DSO support

> Creating Makefile in src

>  + configured for Solaris 2100 platform

>  + setting C compiler to gcc

>  + setting C pre-processor to gcc -E

>  + using "tr [a-z] [A-Z]" to uppercase

>  + checking for system header files

>  + adding selected modules

>  + using builtin Expat

>  + checking sizeof various data types

>  + doing sanity check on compiler and options

> ./Configure: support/Makefile: cannot create

> ./Configure: support/Makefile: cannot create

> Creating Makefile in src/support

> ./Configure: regex/Makefile: cannot create

> ./Configure: regex/Makefile: cannot create

> Creating Makefile in src/regex

> ./Configure: os/unix/Makefile: cannot create

> ./Configure: os/unix/Makefile: cannot create

> Creating Makefile in src/os/unix

> ./Configure: ap/Makefile: cannot create

> ./Configure: ap/Makefile: cannot create

> Creating Makefile in src/ap

> ./Configure: main/Makefile: cannot create

> ./Configure: main/Makefile: cannot create

> ./Configure: lib/Makefile: cannot create

> ./Configure: lib/Makefile: cannot create

> ./Configure: lib/Makefile: cannot create

> Creating Makefile in src/main

> ./Configure: lib/expat-lite/Makefile: cannot create

> ./Configure: lib/expat-lite/Makefile: cannot create

> ./Configure: modules/Makefile: cannot create

> ./Configure: modules/Makefile: cannot create

> ./Configure: modules/Makefile: cannot create

> Creating Makefile in src/lib/expat-lite

> ./Configure: modules/standard/Makefile: cannot create

> ./Configure: modules/standard/Makefile: cannot create

> ./Configure: modules/standard/Makefile: cannot create

> ./Configure: modules/standard/Makefile: cannot create

> Creating Makefile in src/modules/standard

> 

> 2) On executing the "make" command I am getting the following error:

> ===> src

> ===> src/regex

> <=== src/regex

> ===> src/os/unix

> gcc -c  -I../../os/unix -I../../include   -DSOLARIS2=2100 -DUSE_HSREGEX -DUS

> E_EXPAT -I../../lib/expat-lite `../../apaci` os.c

> In file included from /usr/include/signal.h:26,

>                  from /usr/include/sys/siginfo.h:25,

>                  from /usr/include/sys/wait.h:24,

>                  from ../../include/ap_config.h:1079,

>                  from os.c:21:

> /usr/include/sys/signal.h:85: error: parse error before "siginfo_t"

> In file included from /usr/include/sys/siginfo.h:25,

>                  from /usr/include/sys/wait.h:24,

>                  from ../../include/ap_config.h:1079,

>                  from os.c:21:

> /usr/include/signal.h:111: error: parse error before "siginfo_t"

> /usr/include/signal.h:113: error: parse error before "siginfo_t"

> In file included from /usr/include/sys/wait.h:24,

>                  from ../../include/ap_config.h:1079,

>                  from os.c:21:

> /usr/include/sys/siginfo.h:259: error: parse error before "ctid_t"

> /usr/include/sys/siginfo.h:292: error: parse error before '}' token

> /usr/include/sys/siginfo.h:294: error: parse error before '}' token

> /usr/include/sys/siginfo.h:390: error: parse error before "ctid_t"

> /usr/include/sys/siginfo.h:392: error: conflicting types for `__proc'

> /usr/include/sys/siginfo.h:261: error: previous declaration of `__proc'

> /usr/include/sys/siginfo.h:398: error: conflicting types for `__fault'

> /usr/include/sys/siginfo.h:267: error: previous declaration of `__fault'

> /usr/include/sys/siginfo.h:404: error: conflicting types for `__file'

> /usr/include/sys/siginfo.h:273: error: previous declaration of `__file'

> /usr/include/sys/siginfo.h:420: error: conflicting types for `__prof'

> /usr/include/sys/siginfo.h:287: error: previous declaration of `__prof'

> /usr/include/sys/siginfo.h:424: error: conflicting types for `__rctl'

> /usr/include/sys/siginfo.h:291: error: previous declaration of `__rctl'

> /usr/include/sys/siginfo.h:426: error: parse error before '}' token

> /usr/include/sys/siginfo.h:428: error: parse error before '}' token

> /usr/include/sys/siginfo.h:432: error: parse error before "k_siginfo_t"

> /usr/include/sys/siginfo.h:437: error: parse error before '}' token

> In file included from ../../include/ap_config.h:1079,

>                  from os.c:21:

> /usr/include/sys/wait.h:86: error: parse error before "siginfo_t"

> *** Error code 1

> make: Fatal error: Command failed for target `os.o'

> Current working directory /test/self/INs/apache_1.3.33/src/os/unix

> *** Error code 1

> The following command caused the error:

> for i in regex os/unix ap main lib modules; do \

>         echo "===> src/$i"; \

>         case ".Solaris 2100" in \

>           .OS390 | .TPF) ( cd $i && make SDP='src/' OPTIM='') || exit 1;; \

>                       *) ( cd $i && make  SDP='src/' CC='gcc'

> AUX_CFLAGS=' -DSOLARIS2=2100 -DUSE_HSREGEX -DUSE_EXPAT -I./lib/expat-lite

> `./apaci`' RANLIB='ranlib' OPTIM='') || exit 1;; \

>         esac; \

>         echo "<=== src/$i"; \

> done

> make: Fatal error: Command failed for target `subdirs'

> Current working directory /test/self/INs/apache_1.3.33/src

> *** Error code 1

> The following command caused the error:

> case "xsun4u-sun-solaris2.2100" in \

>   x*390*) _C89_STEPS="0xffffffff"; export _C89_STEPS;; \

> esac; \

> cd ./src; make  SDP=src/ all

> make: Fatal error: Command failed for target `build-std'

> Current working directory /test/self/INs/apache_1.3.33

> *** Error code 1

> The following command caused the error:

> make -f ./Makefile  root= build-std

> make: Fatal error: Command failed for target `build'

> 

> Please suggest how can I resolve this issue.

> 

> Thanks,

> Rahul

> 

 

 

---------------------------------------------------------------------

The official User-To-User support forum of the Apache HTTP Server Project.

See <URL:http://httpd.apache.org/userslist.html> for more info.

To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org

   "   from the digest: users-digest-unsubscribe@httpd.apache.org

For additional commands, e-mail: users-help@httpd.apache.org

 

 


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message