httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dick Davies <rasput...@hellooperator.net>
Subject Re: [users@httpd] httpd can't start because it's not yet running
Date Fri, 20 May 2005 09:33:49 GMT
* dan <info@hostinthebox.net> [0559 01:59]:
> Fabiano Sidler wrote:
> >Hi folks!
> >
> >root@host $ httpd -k start
> >(20014)Error string not specified yet: Error retrieving pid file 
> >/var/run/httpd.pid
> >root@host $ ls -l /var/run/httpd.pid -rw-r--r--  1 root root 0 May 20 
> >02:44 /var/run/httpd.pid
> >
> >Same problem with httpd:httpd permissions. 'strace' says:
> >
> >[...]
> >open("/var/run/httpd.pid", O_RDONLY)    = 3
> >read(3, "", 13)                         = 0
> >write(2, "(20014)Error string not specifie"..., 84) = 84
> >[...]
> >
> >Where is the problem?
> >Greetings,
> >fips
> >
> 
> Do you have a PidFile directive in httpd.conf?  Does it match up to 
> where Apache would expect it?

Well it looks like it, doesn't it? Did you see the strace output?

apache opens the file,
tries to read 13 bytes, and hits end of file
no error is thrown.


Looks to me like Apache is reading the pidfile, but it's empty.
Try deleting it and trying again.
 

-- 
'Robots don't have emotions, and that sometimes makes me feel sad.'
		-- Bender
Rasputin :: Jack of All Trades - Master of Nuns

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message